summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-06-10 13:51:20 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-06-10 13:51:20 +0000
commita270de0f971eea1594ac7214f309724b201627cd (patch)
tree2b3383b3a979a1d7775057657e2319292c3b6545 /media-libs/libsdl/libsdl-1.2.8-r1.ebuild
parentAdded to ~ppc (diff)
downloadgentoo-2-a270de0f971eea1594ac7214f309724b201627cd.tar.gz
gentoo-2-a270de0f971eea1594ac7214f309724b201627cd.tar.bz2
gentoo-2-a270de0f971eea1594ac7214f309724b201627cd.zip
Added -msse2 to filter for x86 and closing bug #94377.
Diffstat (limited to 'media-libs/libsdl/libsdl-1.2.8-r1.ebuild')
-rw-r--r--media-libs/libsdl/libsdl-1.2.8-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
index edfc23125b37..6c9f0ac6b116 100644
--- a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.14 2005/06/06 10:07:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.15 2005/06/10 13:51:20 wolf31o2 Exp $
inherit flag-o-matic toolchain-funcs eutils gnuconfig
@@ -79,7 +79,7 @@ src_compile() {
strip-flags -funroll-all-loops -fpeel-loops -fomit-frame-pointer # more bug #74608 and also bug #82618
fi
if use x86 ; then
- filter-flags -fforce-addr #87077
+ filter-flags -fforce-addr -msse2 #87077 and #94377
use pic || myconf="${myconf} $(use_enable x86 nasm)"
fi
use noaudio && myconf="${myconf} --disable-audio"