summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-28 06:50:56 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-28 06:50:56 +0000
commit4a5c3fd4d55feb34958f9980251ee6912af3e572 (patch)
treea707944018175dd8a85375a68e663d433427ac11 /media-libs/libraw
parentRevert to autotools eclass. (diff)
downloadgentoo-2-4a5c3fd4d55feb34958f9980251ee6912af3e572.tar.gz
gentoo-2-4a5c3fd4d55feb34958f9980251ee6912af3e572.tar.bz2
gentoo-2-4a5c3fd4d55feb34958f9980251ee6912af3e572.zip
Fix autotools-utils usage.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libraw')
-rw-r--r--media-libs/libraw/ChangeLog5
-rw-r--r--media-libs/libraw/libraw-0.14.3.ebuild25
2 files changed, 17 insertions, 13 deletions
diff --git a/media-libs/libraw/ChangeLog b/media-libs/libraw/ChangeLog
index 256868845b3e..9d0c1e38b0a0 100644
--- a/media-libs/libraw/ChangeLog
+++ b/media-libs/libraw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libraw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.15 2011/11/27 04:12:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.16 2011/11/28 06:50:56 radhermit Exp $
+
+ 28 Nov 2011; Tim Harder <radhermit@gentoo.org> libraw-0.14.3.ebuild:
+ Fix autotools-utils usage.
27 Nov 2011; Tim Harder <radhermit@gentoo.org> libraw-0.14.3.ebuild:
Build in the source tree.
diff --git a/media-libs/libraw/libraw-0.14.3.ebuild b/media-libs/libraw/libraw-0.14.3.ebuild
index d1bd1d947d46..bbd8c4fbc172 100644
--- a/media-libs/libraw/libraw-0.14.3.ebuild
+++ b/media-libs/libraw/libraw-0.14.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/libraw-0.14.3.ebuild,v 1.2 2011/11/27 04:12:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/libraw-0.14.3.ebuild,v 1.3 2011/11/28 06:50:56 radhermit Exp $
EAPI="4"
-inherit eutils autotools-utils
+inherit autotools-utils
MY_P="LibRaw-${PV}"
DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
@@ -31,20 +31,21 @@ S="${WORKDIR}/${MY_P}"
DOCS=( Changelog.txt README )
-AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}"/${PN}-0.13.4-docs.patch )
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.13.4-docs.patch
+ autotools-utils_src_prepare
eautomake
}
src_configure() {
- econf \
- $(use_enable demosaic demosaic-pack-gpl2) \
- $(use_enable demosaic demosaic-pack-gpl3) \
- $(use_enable examples) \
- $(use_enable jpeg2k jasper) \
- $(use_enable lcms) \
- $(use_enable openmp) \
- $(use_enable static-libs static)
+ local myeconfargs=(
+ $(use_enable demosaic demosaic-pack-gpl2)
+ $(use_enable demosaic demosaic-pack-gpl3)
+ $(use_enable examples)
+ $(use_enable jpeg2k jasper)
+ $(use_enable lcms)
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
}