summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-09-11 20:03:16 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-09-11 20:03:16 +0000
commitc410154f9e2d46865448e167906bc77ee16f21e7 (patch)
treeef4aea8dc10cca5b6a59ad7086872bbe7f4c49ba /media-libs/libpgf/libpgf-6.11.32.ebuild
parentMask jdk/jre 1.7 until icedtea7 is ready, bug #382485. (diff)
downloadgentoo-2-c410154f9e2d46865448e167906bc77ee16f21e7.tar.gz
gentoo-2-c410154f9e2d46865448e167906bc77ee16f21e7.tar.bz2
gentoo-2-c410154f9e2d46865448e167906bc77ee16f21e7.zip
Version bump because of ppc bugfixes; remove ppc keyword in previous version
(Portage version: 2.1.10.14/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libpgf/libpgf-6.11.32.ebuild')
-rw-r--r--media-libs/libpgf/libpgf-6.11.32.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/libpgf/libpgf-6.11.32.ebuild b/media-libs/libpgf/libpgf-6.11.32.ebuild
new file mode 100644
index 000000000000..c4a4e6b07223
--- /dev/null
+++ b/media-libs/libpgf/libpgf-6.11.32.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpgf/libpgf-6.11.32.ebuild,v 1.1 2011/09/11 20:03:16 dilfridge Exp $
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="Library to load, handle and manipulate images in the PGF format"
+HOMEPAGE="http://www.libpgf.org/"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ if ! use doc; then
+ sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}