summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-15 10:47:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-15 10:47:35 +0000
commit3e5adef57ef617cecb6312d6fabd48dcac248e7c (patch)
treec854599843c60b86351e2bcf83825a402bbaa5f7 /media-libs/libopenraw
parentVersion bump. The new version fixes pthread optionality and uses libtinynotify. (diff)
downloadgentoo-2-3e5adef57ef617cecb6312d6fabd48dcac248e7c.tar.gz
gentoo-2-3e5adef57ef617cecb6312d6fabd48dcac248e7c.tar.bz2
gentoo-2-3e5adef57ef617cecb6312d6fabd48dcac248e7c.zip
Fix gdk-pixbuf path wrt #383045 by Priit Laes
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libopenraw')
-rw-r--r--media-libs/libopenraw/ChangeLog9
-rw-r--r--media-libs/libopenraw/files/libopenraw-0.0.8-fix_gdk-pixbuf_path.patch35
-rw-r--r--media-libs/libopenraw/libopenraw-0.0.8-r1.ebuild41
3 files changed, 84 insertions, 1 deletions
diff --git a/media-libs/libopenraw/ChangeLog b/media-libs/libopenraw/ChangeLog
index 4f2567d9ff58..c21e8828ee7e 100644
--- a/media-libs/libopenraw/ChangeLog
+++ b/media-libs/libopenraw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libopenraw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libopenraw/ChangeLog,v 1.48 2011/03/28 17:18:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libopenraw/ChangeLog,v 1.49 2011/09/15 10:47:35 ssuominen Exp $
+
+*libopenraw-0.0.8-r1 (15 Sep 2011)
+
+ 15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +libopenraw-0.0.8-r1.ebuild,
+ +files/libopenraw-0.0.8-fix_gdk-pixbuf_path.patch:
+ Fix gdk-pixbuf path wrt #383045 by Priit Laes
28 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> libopenraw-0.0.8.ebuild:
Remove useless libtool archive files.
diff --git a/media-libs/libopenraw/files/libopenraw-0.0.8-fix_gdk-pixbuf_path.patch b/media-libs/libopenraw/files/libopenraw-0.0.8-fix_gdk-pixbuf_path.patch
new file mode 100644
index 000000000000..82557875a7f6
--- /dev/null
+++ b/media-libs/libopenraw/files/libopenraw-0.0.8-fix_gdk-pixbuf_path.patch
@@ -0,0 +1,35 @@
+From 252cd9b20d7857091c0529955998b86d7a90e6c5 Mon Sep 17 00:00:00 2001
+From: Hubert Figuiere <hub@figuiere.net>
+Date: Thu, 22 Jul 2010 07:04:54 +0000
+Subject: Install the GdkPixbuf in the right place. (Closes #29208) (Vincent Untz)
+
+---
+diff --git a/configure.in b/configure.in
+index 1d44b9c..c16a20c 100644
+--- a/configure.in
++++ b/configure.in
+@@ -137,8 +137,7 @@ if test x$enable_gnome = xyes ; then
+ if test x$HAVE_LIBGLIB = xyes ; then
+ PKG_CHECK_MODULES(LIBGDKPIXBUF, gdk-pixbuf-2.0 >= $LIBGDKPIXBUF_REQUIRED,
+ [AC_DEFINE(HAVE_LIBGDKPIXBUF, 1, [Define to 1 to enable libgdkpixbuf support])
+- GTK_VERSION=`$PKG_CONFIG --variable=gtk_binary_version gtk+-2.0`
+- GDK_PIXBUF_DIR="gtk-2.0/$GTK_VERSION/loaders"
++ GDK_PIXBUF_DIR=`$PKG_CONFIG --variable=gdk_pixbuf_moduledir gdk-pixbuf-2.0`
+ AC_SUBST(GDK_PIXBUF_DIR)
+ HAVE_LIBGDKPIXBUF=yes],
+ [HAVE_LIBGDKPIXBUF=no])
+diff --git a/gnome/Makefile.am b/gnome/Makefile.am
+index ecfe27d..2c0bca5 100644
+--- a/gnome/Makefile.am
++++ b/gnome/Makefile.am
+@@ -16,7 +16,7 @@ pkgconfig_DATA = $(PKG_CONFIG_FILES)
+
+ lib_LTLIBRARIES = $(GNOME_TARGETS)
+
+-loaderdir = $(libdir)/$(GDK_PIXBUF_DIR)
++loaderdir = $(GDK_PIXBUF_DIR)
+ loader_LTLIBRARIES = $(GDK_PIXBUF_PLUGIN)
+
+ libopenrawgnome_la_LDFLAGS = \
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/media-libs/libopenraw/libopenraw-0.0.8-r1.ebuild b/media-libs/libopenraw/libopenraw-0.0.8-r1.ebuild
new file mode 100644
index 000000000000..eaa852d32278
--- /dev/null
+++ b/media-libs/libopenraw/libopenraw-0.0.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libopenraw/libopenraw-0.0.8-r1.ebuild,v 1.1 2011/09/15 10:47:35 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A decoding library for RAW image formats"
+HOMEPAGE="http://libopenraw.freedesktop.org"
+SRC_URI="http://${PN}.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk static-libs test"
+
+RDEPEND="virtual/jpeg
+ dev-libs/libxml2
+ gtk? ( >=x11-libs/gdk-pixbuf-2.24.0:2 )"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.35
+ dev-util/pkgconfig
+ test? ( net-misc/curl )"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix_gdk-pixbuf_path.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable gtk gnome)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f {} +
+}