summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-25 08:56:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-25 08:56:04 +0000
commit2b11f8a00be6fabf9d8a4b230ae06d8e8cde3b0b (patch)
treed1aea787b2f4e1e426c2788cf96eb7e05fad3860 /media-libs/libogg/libogg-1.1.4.ebuild
parentwhitespace (diff)
downloadgentoo-2-2b11f8a00be6fabf9d8a4b230ae06d8e8cde3b0b.tar.gz
gentoo-2-2b11f8a00be6fabf9d8a4b230ae06d8e8cde3b0b.tar.bz2
gentoo-2-2b11f8a00be6fabf9d8a4b230ae06d8e8cde3b0b.zip
version bump, by Arseny Solokha <b0ntrict0r@yandex.ru>, bug #275348
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libogg/libogg-1.1.4.ebuild')
-rw-r--r--media-libs/libogg/libogg-1.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/libogg/libogg-1.1.4.ebuild b/media-libs/libogg/libogg-1.1.4.ebuild
new file mode 100644
index 000000000000..f54a5b719c26
--- /dev/null
+++ b/media-libs/libogg/libogg-1.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libogg/libogg-1.1.4.ebuild,v 1.1 2009/06/25 08:56:04 aballier Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="the Ogg media file format library"
+HOMEPAGE="http://xiph.org/ogg/"
+SRC_URI="http://downloads.xiph.org/releases/ogg/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES AUTHORS
+
+ find "${D}" -name '*.la' -delete
+}