summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-02-24 17:42:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-02-24 17:42:26 +0000
commit70385a2334271b625d517b7e493a9b336e5b6be6 (patch)
tree7056439fa796c9ec5a6f2b62bc949abb789cbf54 /media-libs/libmatroska
parentVersion bump. Thanks nesl247 for poke. (diff)
downloadgentoo-2-70385a2334271b625d517b7e493a9b336e5b6be6.tar.gz
gentoo-2-70385a2334271b625d517b7e493a9b336e5b6be6.tar.bz2
gentoo-2-70385a2334271b625d517b7e493a9b336e5b6be6.zip
version bump
(Portage version: 2.1.2-r11)
Diffstat (limited to 'media-libs/libmatroska')
-rw-r--r--media-libs/libmatroska/ChangeLog10
-rw-r--r--media-libs/libmatroska/files/digest-libmatroska-0.8.13
-rw-r--r--media-libs/libmatroska/files/libmatroska-0.8.1-respectflags.patch11
-rw-r--r--media-libs/libmatroska/libmatroska-0.8.1.ebuild41
4 files changed, 63 insertions, 2 deletions
diff --git a/media-libs/libmatroska/ChangeLog b/media-libs/libmatroska/ChangeLog
index 5fcb2fec2ce3..19d8a975e2ee 100644
--- a/media-libs/libmatroska/ChangeLog
+++ b/media-libs/libmatroska/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmatroska
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.73 2006/10/20 21:47:16 kloeri Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.74 2007/02/24 17:42:26 aballier Exp $
+
+*libmatroska-0.8.1 (24 Feb 2007)
+
+ 24 Feb 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/libmatroska-0.8.1-respectflags.patch, +libmatroska-0.8.1.ebuild:
+ Version bump
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
libmatroska-0.8.0.ebuild:
diff --git a/media-libs/libmatroska/files/digest-libmatroska-0.8.1 b/media-libs/libmatroska/files/digest-libmatroska-0.8.1
new file mode 100644
index 000000000000..def099070ca1
--- /dev/null
+++ b/media-libs/libmatroska/files/digest-libmatroska-0.8.1
@@ -0,0 +1,3 @@
+MD5 2ceb8235e5189fe4e79ec25ebd97b56b libmatroska-0.8.1.tar.bz2 91430
+RMD160 ad6667222e723ac5aa4e42527fd35fd678eb3d9a libmatroska-0.8.1.tar.bz2 91430
+SHA256 ee1f0c6a975ee14dd8b4b28b75d8f7a9f8498210d82e74411dbe95871382a7e9 libmatroska-0.8.1.tar.bz2 91430
diff --git a/media-libs/libmatroska/files/libmatroska-0.8.1-respectflags.patch b/media-libs/libmatroska/files/libmatroska-0.8.1-respectflags.patch
new file mode 100644
index 000000000000..de9e302f7894
--- /dev/null
+++ b/media-libs/libmatroska/files/libmatroska-0.8.1-respectflags.patch
@@ -0,0 +1,11 @@
+--- make/linux/Makefile.old 2007-02-24 17:51:03.000000000 +0100
++++ make/linux/Makefile 2007-02-24 17:52:24.000000000 +0100
+@@ -102,7 +102,7 @@
+ $(RANLIB) $@
+
+ $(LIBRARY_SO): $(objects_so)
+- $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) -lebml
++ $(CXX) $(LINKFLAGS) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) -lebml
+ rm -f $(LIBRARY_SO)
+ ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
+
diff --git a/media-libs/libmatroska/libmatroska-0.8.1.ebuild b/media-libs/libmatroska/libmatroska-0.8.1.ebuild
new file mode 100644
index 000000000000..35c4322d1f9f
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-0.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/libmatroska-0.8.1.ebuild,v 1.1 2007/02/24 17:42:26 aballier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libebml-0.7.6"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-respectflags.patch"
+}
+
+src_compile() {
+ cd "${S}/make/linux"
+
+ #fixes locale for gcc3.4.0 to close bug 52385
+ append-flags $(test-flags -finput-charset=ISO8859-15)
+
+ emake PREFIX=/usr \
+ LIBEBML_INCLUDE_DIR=/usr/include/ebml \
+ LIBEBML_LIB_DIR=/usr/$(get_libdir) \
+ CXX="$(tc-getCXX)" || die "make failed"
+}
+
+src_install() {
+ cd "${S}/make/linux"
+
+ emake prefix="${D}/usr" libdir="${D}/usr/$(get_libdir)" install || die "make install failed"
+ dodoc "${S}/ChangeLog"
+}