summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-30 16:05:52 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-30 16:05:52 +0000
commitb5aa091ceaec7b98ca79a712c19bfe5cf3cf68b3 (patch)
treef33fdc73fc20af4f09eb4b927d6e743b225eeeb1 /media-libs/libirman/libirman-0.4.5.ebuild
parentversion bump (diff)
downloadgentoo-2-b5aa091ceaec7b98ca79a712c19bfe5cf3cf68b3.tar.gz
gentoo-2-b5aa091ceaec7b98ca79a712c19bfe5cf3cf68b3.tar.bz2
gentoo-2-b5aa091ceaec7b98ca79a712c19bfe5cf3cf68b3.zip
media-libs/libirman: Regenerate autotool files in order to allow parallel install, #423879
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libirman/libirman-0.4.5.ebuild')
-rw-r--r--media-libs/libirman/libirman-0.4.5.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/media-libs/libirman/libirman-0.4.5.ebuild b/media-libs/libirman/libirman-0.4.5.ebuild
index 9d71c5acc507..b989c2d546e6 100644
--- a/media-libs/libirman/libirman-0.4.5.ebuild
+++ b/media-libs/libirman/libirman-0.4.5.ebuild
@@ -1,34 +1,31 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/libirman-0.4.5.ebuild,v 1.1 2012/05/06 16:15:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/libirman-0.4.5.ebuild,v 1.2 2012/06/30 16:05:52 jlec Exp $
EAPI=4
-inherit eutils toolchain-funcs
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils eutils toolchain-funcs
DESCRIPTION="library for Irman control of Unix software"
-SRC_URI="http://www.lirc.org/software/snapshots/${P}.tar.bz2"
HOMEPAGE="http://www.lirc.org/software/snapshots/"
+SRC_URI="http://www.lirc.org/software/snapshots/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2 LGPL-2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="static-libs"
-pkg_setup() {
- tc-export CC LD AR RANLIB
-}
+DOCS=( TECHNICAL NEWS README TODO )
-src_configure() {
- econf --disable-static
+src_prepare() {
+ tc-export CC LD AR RANLIB
+ autotools-utils_src_prepare
}
src_install() {
- dodir /usr/include
-
- emake DESTDIR="${D}" LIRC_DRIVER_DEVICE="${D}/dev/lirc" install
-
- dobin test_func test_io test_name
- dodoc NEWS README* TECHNICAL TODO
+ autotools-utils_src_install LIRC_DRIVER_DEVICE="${D}/dev/lirc"
- find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dobin ${AUTOTOOLS_BUILD_DIR}/test_{func,io,name}
}