summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-24 12:04:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-24 12:04:51 +0000
commit9de7b232d87194587362399763e5a4b96363be2c (patch)
tree623c58771ae0b70f48cf9e0aa68e658ac046d09e /media-libs/libgpod
parentStable on amd64; bug 218927 (diff)
downloadgentoo-2-9de7b232d87194587362399763e5a4b96363be2c.tar.gz
gentoo-2-9de7b232d87194587362399763e5a4b96363be2c.tar.bz2
gentoo-2-9de7b232d87194587362399763e5a4b96363be2c.zip
Add patch to build with GCC 4.3. thanks to ape in bug #217017.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog6
-rw-r--r--media-libs/libgpod/files/libgpod-0.6.0+gcc-4.3.patch10
-rw-r--r--media-libs/libgpod/libgpod-0.6.0.ebuild13
3 files changed, 26 insertions, 3 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index 3f8a8f023626..75bd9a3a11eb 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libgpod
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.48 2008/04/09 12:39:11 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.49 2008/04/24 12:04:50 flameeyes Exp $
+
+ 24 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libgpod-0.6.0+gcc-4.3.patch, libgpod-0.6.0.ebuild:
+ Add patch to build with GCC 4.3. thanks to ape in bug #217017.
09 Apr 2008; Olivier Crête <tester@gentoo.org>
-files/libgpod-0.4.0-test-nogdk.patch, -libgpod-0.4.0.ebuild,
diff --git a/media-libs/libgpod/files/libgpod-0.6.0+gcc-4.3.patch b/media-libs/libgpod/files/libgpod-0.6.0+gcc-4.3.patch
new file mode 100644
index 000000000000..1e5dfe890237
--- /dev/null
+++ b/media-libs/libgpod/files/libgpod-0.6.0+gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- media-libs/libgpod-0.6.0/work/libgpod-0.6.0/tests/test-rebuild-db.cc 2007-06-02 10:56:58.000000000 +0200
++++ test-rebuild-db.cc 2008-04-09 14:28:09.000000000 +0200
+@@ -29,6 +29,7 @@
+ #include <sys/stat.h>
+ #include <typeinfo>
+ #include <unistd.h>
++#include <cstring>
+
+ #include <glib/gstdio.h>
+
diff --git a/media-libs/libgpod/libgpod-0.6.0.ebuild b/media-libs/libgpod/libgpod-0.6.0.ebuild
index 98fa3bc87c0d..e318b328ece8 100644
--- a/media-libs/libgpod/libgpod-0.6.0.ebuild
+++ b/media-libs/libgpod/libgpod-0.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.6.0.ebuild,v 1.6 2008/04/09 12:39:11 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.6.0.ebuild,v 1.7 2008/04/24 12:04:50 flameeyes Exp $
-inherit eutils
+inherit eutils libtool
DESCRIPTION="Shared library to access the contents of an iPod"
HOMEPAGE="http://www.gtkpod.org/libgpod.html"
@@ -27,6 +27,15 @@ DEPEND="${RDEPEND}
python? ( >=dev-lang/swig-1.3.24 )
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}+gcc-4.3.patch"
+
+ elibtoolize
+}
+
src_compile() {
local myconf