summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-08 14:49:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-08 14:49:49 +0000
commit828cbe6128b41d65acab986a10e1724c06211ec0 (patch)
treef75be66a8a6c38c21d57c587020a31007b599a46 /media-libs/libgpod
parentStable ppc, bug #418525 (diff)
downloadgentoo-2-828cbe6128b41d65acab986a10e1724c06211ec0.tar.gz
gentoo-2-828cbe6128b41d65acab986a10e1724c06211ec0.tar.bz2
gentoo-2-828cbe6128b41d65acab986a10e1724c06211ec0.zip
Query udev.pc pkg-config file for udevdir value to be compatible with sys-fs/udev >= 187.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog6
-rw-r--r--media-libs/libgpod/libgpod-0.8.2.ebuild10
2 files changed, 12 insertions, 4 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index 22c13d65cb3a..a42aced409a0 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libgpod
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.90 2012/05/05 08:02:25 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.91 2012/08/08 14:49:49 ssuominen Exp $
+
+ 08 Aug 2012; Samuli Suominen <ssuominen@gentoo.org> libgpod-0.8.2.ebuild:
+ Query udev.pc pkg-config file for udevdir value to be compatible with
+ sys-fs/udev >= 187.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> libgpod-0.8.0.ebuild,
libgpod-0.8.2.ebuild:
diff --git a/media-libs/libgpod/libgpod-0.8.2.ebuild b/media-libs/libgpod/libgpod-0.8.2.ebuild
index f6637b686593..818f36eaf3f6 100644
--- a/media-libs/libgpod/libgpod-0.8.2.ebuild
+++ b/media-libs/libgpod/libgpod-0.8.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.8.2.ebuild,v 1.4 2012/05/05 08:02:25 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.8.2.ebuild,v 1.5 2012/08/08 14:49:49 ssuominen Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
-inherit mono python
+inherit eutils mono python toolchain-funcs
DESCRIPTION="Shared library to access the contents of an iPod"
HOMEPAGE="http://www.gtkpod.org/libgpod/"
@@ -53,6 +53,9 @@ src_prepare() {
}
src_configure() {
+ local udevdir=/lib/udev
+ use udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+
econf \
$(use_enable static-libs static) \
$(use_enable udev) \
@@ -60,6 +63,7 @@ src_configure() {
$(use_enable python pygobject) \
--without-hal \
$(use_with ios libimobiledevice) \
+ --with-udev-dir="${udevdir}" \
--with-html-dir=/usr/share/doc/${PF}/html \
$(use_with python) \
$(use_with mono)
@@ -67,7 +71,7 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -exec rm -f {} +
+ prune_libtool_files --all
}
pkg_postinst() {