summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-16 19:46:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-16 19:46:20 +0000
commit56bf2c18cf5e0a5d9b1e3fab626a65ed4abf569e (patch)
treebf30564594fa1077cbc594a5a7b2b9ab862748fd /media-libs/libgpod
parentVerbump. (diff)
downloadgentoo-2-56bf2c18cf5e0a5d9b1e3fab626a65ed4abf569e.tar.gz
gentoo-2-56bf2c18cf5e0a5d9b1e3fab626a65ed4abf569e.tar.bz2
gentoo-2-56bf2c18cf5e0a5d9b1e3fab626a65ed4abf569e.zip
Raise to eapi4 for last commit
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/libgpod-0.8.2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/media-libs/libgpod/libgpod-0.8.2.ebuild b/media-libs/libgpod/libgpod-0.8.2.ebuild
index a750ade01e13..3385493a5444 100644
--- a/media-libs/libgpod/libgpod-0.8.2.ebuild
+++ b/media-libs/libgpod/libgpod-0.8.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.8.2.ebuild,v 1.1 2012/03/16 19:43:35 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.8.2.ebuild,v 1.2 2012/03/16 19:46:20 ssuominen Exp $
-EAPI=3
+EAPI=4
PYTHON_DEPEND="python? 2:2.6"
@@ -39,6 +39,8 @@ DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
+DOCS="AUTHORS NEWS README* TROUBLESHOOTING"
+
pkg_setup() {
if use python; then
python_set_active_version 2
@@ -52,7 +54,6 @@ src_prepare() {
src_configure() {
econf \
- --disable-dependency-tracking \
$(use_enable static-libs static) \
$(use_enable udev) \
$(use_enable gtk gdk-pixbuf) \
@@ -65,9 +66,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS NEWS README* TROUBLESHOOTING
-
+ default
find "${D}" -name '*.la' -exec rm -f {} +
}