summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-14 23:50:13 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-14 23:50:13 +0000
commitd5e7fc384e75f7445a164cf450a48e4d1f9adaa9 (patch)
tree76212ef456b19ece2bae4dbe35f5c124cdea8888 /media-libs/libflash
parentForgot to install /etc/init.d/authdaemond (diff)
downloadgentoo-2-d5e7fc384e75f7445a164cf450a48e4d1f9adaa9.tar.gz
gentoo-2-d5e7fc384e75f7445a164cf450a48e4d1f9adaa9.tar.bz2
gentoo-2-d5e7fc384e75f7445a164cf450a48e4d1f9adaa9.zip
Update libflash so it works with all compilers thanks to Cardoe!
Diffstat (limited to 'media-libs/libflash')
-rw-r--r--media-libs/libflash/ChangeLog10
-rw-r--r--media-libs/libflash/files/digest-libflash-0.4.10-r11
-rw-r--r--media-libs/libflash/files/libflash-0.4.10-sqrt.patch11
-rw-r--r--media-libs/libflash/libflash-0.4.10-r1.ebuild41
4 files changed, 62 insertions, 1 deletions
diff --git a/media-libs/libflash/ChangeLog b/media-libs/libflash/ChangeLog
index 8968129c9ebb..bc385165e3db 100644
--- a/media-libs/libflash/ChangeLog
+++ b/media-libs/libflash/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libflash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/ChangeLog,v 1.1 2002/02/01 21:53:30 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/ChangeLog,v 1.2 2002/06/14 23:50:13 lostlogic Exp $
+
+*libflash-0.4.10-r1 (14 Jun 2002)
+
+ 14 Jun 2002; Doug Goldstein (Cardoe) <dougg@ufl.edu> libflash-0.4.10-r1.ebuild :
+
+ Fixed some redundant stuff in the ebuild and the major thing is I included a patch
+ that makes it actually compile with gcc3.1. The patch has no effect on gcc2.95 and
+ has been confirmed to compile on both platforms.
*libflash-0.4.10 (1 Feb 2002)
diff --git a/media-libs/libflash/files/digest-libflash-0.4.10-r1 b/media-libs/libflash/files/digest-libflash-0.4.10-r1
new file mode 100644
index 000000000000..fd5039cd658b
--- /dev/null
+++ b/media-libs/libflash/files/digest-libflash-0.4.10-r1
@@ -0,0 +1 @@
+MD5 8dcb1b64115f67bd0982d5e8cc842ad0 libflash-0.4.10.tar.gz 176876
diff --git a/media-libs/libflash/files/libflash-0.4.10-sqrt.patch b/media-libs/libflash/files/libflash-0.4.10-sqrt.patch
new file mode 100644
index 000000000000..59db682f6554
--- /dev/null
+++ b/media-libs/libflash/files/libflash-0.4.10-sqrt.patch
@@ -0,0 +1,11 @@
+diff -C 2 -P -r libflash-orig/lib/shape.cc libflash-0.4.10/lib/shape.cc
+*** libflash-orig/lib/shape.cc Fri Jun 14 18:17:39 2002
+--- libflash-0.4.10/lib/shape.cc Fri Jun 14 18:18:09 2002
+***************
+*** 22,25 ****
+--- 22,26 ----
+
+ #include "swf.h"
++ #include <math.h>
+
+ #ifdef RCSID
diff --git a/media-libs/libflash/libflash-0.4.10-r1.ebuild b/media-libs/libflash/libflash-0.4.10-r1.ebuild
new file mode 100644
index 000000000000..c78f43859239
--- /dev/null
+++ b/media-libs/libflash/libflash-0.4.10-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/libflash-0.4.10-r1.ebuild,v 1.1 2002/06/14 23:50:13 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A library for flash animations"
+SRC_URI="http://www.directfb.org/download/contrib/${P}.tar.gz"
+HOMEPAGE="http://www.swift-tools.com/Flash/"
+
+DEPEND="virtual/glibc
+ media-libs/jpeg
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL"
+SLOT="0"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+
+ # patch to fix the sqrt not defined problem in gcc3.1
+ # It should be ok with gcc2.95 thanks to Doug Goldstein <dougg@ufl.edu> (Cardoe)
+ patch -p0 < ${FILESDIR}/${P}-sqrt.patch || die
+
+}
+
+src_compile() {
+
+ econf || die "Configure failed"
+ emake || die "Make failed"
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Install failed"
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+
+}
+