summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-18 16:39:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-18 16:39:10 +0000
commita0b8016447963927a6fe1f611feacbcae8438470 (patch)
tree33cf085a0a60b3fae0d27640e5e97b1e6b0ff4c8 /media-libs/libfishsound/libfishsound-0.8.1.ebuild
parentSparc stable --- Security Bug #196735 --- works as always. (diff)
downloadgentoo-2-a0b8016447963927a6fe1f611feacbcae8438470.tar.gz
gentoo-2-a0b8016447963927a6fe1f611feacbcae8438470.tar.bz2
gentoo-2-a0b8016447963927a6fe1f611feacbcae8438470.zip
initial import
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-libs/libfishsound/libfishsound-0.8.1.ebuild')
-rw-r--r--media-libs/libfishsound/libfishsound-0.8.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/libfishsound/libfishsound-0.8.1.ebuild b/media-libs/libfishsound/libfishsound-0.8.1.ebuild
new file mode 100644
index 000000000000..e3a5bea550cc
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-0.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/libfishsound-0.8.1.ebuild,v 1.1 2007/11/18 16:39:09 aballier Exp $
+
+DESCRIPTION="Simple programming interface for decoding and encoding audio data using Xiph.Org codecs (Vorbis and Speex)"
+HOMEPAGE="http://www.annodex.net/software/libfishsound/html/"
+SRC_URI="http://www.annodex.net/software/libfishsound/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc vorbis"
+
+RDEPEND="vorbis? ( media-libs/libvorbis media-libs/libogg )
+ media-libs/speex"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen virtual/latex-base )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use doc || sed -i -e "s/doxygen/doxygen-dummy/" configure
+ rm -rf "${S}/doc/libfishsound"
+
+}
+
+src_compile() {
+ local myconf
+ use vorbis || myconf="--disable-vorbis"
+ econf $myconf
+
+ emake || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ cd "${S}/doc/libfishsound/latex"
+ emake refman.ps || die "failed to create refman.ps"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}