summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-14 18:18:51 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-14 18:18:51 +0000
commitc6b057640deebcdbeb0f9b19f424da1c27a41700 (patch)
tree66bcfa556e8006d5cb55e96039d471163401396c /media-libs/libexif
parentStable on ppc wrt bug 221063 (diff)
downloadgentoo-2-c6b057640deebcdbeb0f9b19f424da1c27a41700.tar.gz
gentoo-2-c6b057640deebcdbeb0f9b19f424da1c27a41700.tar.bz2
gentoo-2-c6b057640deebcdbeb0f9b19f424da1c27a41700.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'media-libs/libexif')
-rw-r--r--media-libs/libexif/ChangeLog10
-rw-r--r--media-libs/libexif/libexif-0.6.16-r1.ebuild9
-rw-r--r--media-libs/libexif/libexif-0.6.16.ebuild11
3 files changed, 23 insertions, 7 deletions
diff --git a/media-libs/libexif/ChangeLog b/media-libs/libexif/ChangeLog
index 77f132c1aa61..6eabad21726e 100644
--- a/media-libs/libexif/ChangeLog
+++ b/media-libs/libexif/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libexif
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.94 2007/12/19 16:23:53 armin76 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.95 2008/06/14 18:18:51 zmedico Exp $
+
+ 14 Jun 2008; Zac Medico <zmedico@gentoo.org> libexif-0.6.16.ebuild,
+ libexif-0.6.16-r1.ebuild:
+ Bug #226505 - For compatibility with phase execution order in
+ >=portage-2.1.5, call has_version inside pkg_preinst instead of
+ pkg_postinst.
19 Dec 2007; Raúl Porcel <armin76@gentoo.org> libexif-0.6.16-r1.ebuild:
alpha/ia64/x86 stable wrt security #202350
diff --git a/media-libs/libexif/libexif-0.6.16-r1.ebuild b/media-libs/libexif/libexif-0.6.16-r1.ebuild
index 42e9f0f338a6..54404cd4b3d8 100644
--- a/media-libs/libexif/libexif-0.6.16-r1.ebuild
+++ b/media-libs/libexif/libexif-0.6.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.16-r1.ebuild,v 1.7 2008/01/10 08:52:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.16-r1.ebuild,v 1.8 2008/06/14 18:18:51 zmedico Exp $
inherit eutils libtool
@@ -54,8 +54,13 @@ src_install() {
use nls || rm -rf "${D}usr/share/locale"
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.6.13-r2"
+ previous_less_than_0_6_13_r2=$?
+}
+
pkg_postinst() {
- if has_version '<media-libs/libexif-0.6.13-r2'; then
+ if [[ $previous_less_than_0_6_13_r2 = 0 ]] ; then
elog "If you are upgrading from a version of libexif older than 0.6.13-r2,"
elog "you will need to do the following to rebuild dependencies:"
elog "# revdep-rebuild --soname libexif.so.9"
diff --git a/media-libs/libexif/libexif-0.6.16.ebuild b/media-libs/libexif/libexif-0.6.16.ebuild
index b7fc859d0487..5e56cabff539 100644
--- a/media-libs/libexif/libexif-0.6.16.ebuild
+++ b/media-libs/libexif/libexif-0.6.16.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.16.ebuild,v 1.12 2007/12/18 17:33:40 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.16.ebuild,v 1.13 2008/06/14 18:18:51 zmedico Exp $
inherit eutils libtool
@@ -52,8 +52,13 @@ src_install() {
use nls || rm -rf "${D}usr/share/locale"
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.6.13-r2"
+ previous_less_than_0_6_13_r2=$?
+}
+
pkg_postinst() {
- if has_version '<media-libs/libexif-0.6.13-r2'; then
+ if [[ $previous_less_than_0_6_13_r2 = 0 ]] ; then
elog "If you are upgrading from a version of libexif older than 0.6.13-r2,"
elog "you will need to do the following to rebuild dependencies:"
elog "# revdep-rebuild --soname libexif.so.9"