summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2007-06-05 08:39:38 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2007-06-05 08:39:38 +0000
commita90214182a1de99d215a653268db83a85bd28c2f (patch)
tree4e38f800504c625c845b7dff7cfaa0ff3dcdc8f4 /media-libs/libexif
parentadded 2.2.5 version (diff)
downloadgentoo-2-a90214182a1de99d215a653268db83a85bd28c2f.tar.gz
gentoo-2-a90214182a1de99d215a653268db83a85bd28c2f.tar.bz2
gentoo-2-a90214182a1de99d215a653268db83a85bd28c2f.zip
Added elog information about soname change. Fixed USE=-doc.
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-libs/libexif')
-rw-r--r--media-libs/libexif/ChangeLog6
-rw-r--r--media-libs/libexif/libexif-0.6.15-r1.ebuild18
-rw-r--r--media-libs/libexif/libexif-0.6.15.ebuild17
3 files changed, 32 insertions, 9 deletions
diff --git a/media-libs/libexif/ChangeLog b/media-libs/libexif/ChangeLog
index e0360f9f0056..3a26f774bef6 100644
--- a/media-libs/libexif/ChangeLog
+++ b/media-libs/libexif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libexif
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.75 2007/05/31 10:41:26 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.76 2007/06/05 08:39:38 eradicator Exp $
+
+ 05 Jun 2007; Jeremy Huddleston <eradicator@gentoo.org>
+ libexif-0.6.15.ebuild, libexif-0.6.15-r1.ebuild:
+ Added elog information about soname change. Fixed USE=-doc.
*libexif-0.6.15-r1 (31 May 2007)
diff --git a/media-libs/libexif/libexif-0.6.15-r1.ebuild b/media-libs/libexif/libexif-0.6.15-r1.ebuild
index 21cb67b16d7f..1c0b384d8283 100644
--- a/media-libs/libexif/libexif-0.6.15-r1.ebuild
+++ b/media-libs/libexif/libexif-0.6.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.15-r1.ebuild,v 1.1 2007/05/31 10:41:26 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.15-r1.ebuild,v 1.2 2007/06/05 08:39:38 eradicator Exp $
inherit eutils libtool
@@ -30,10 +30,9 @@ src_unpack() {
}
src_compile() {
- local my_conf
- use doc && my_conf="--with-doc-dir=/usr/share/doc/${PF}"
+ local my_conf="--with-doc-dir=/usr/share/doc/${PF}"
use nls || my_conf="${my_conf} --without-libintl-prefix"
- econf $(use_enable nls) $(use_enable doc) \
+ econf $(use_enable nls) $(use_enable doc docs) \
--with-pic --disable-rpath ${my_conf} || die
emake || die
}
@@ -52,3 +51,14 @@ src_install() {
# installs a blank directory for whatever broken reason
use nls || rm -rf ${D}usr/share/locale
}
+
+pkg_postinst() {
+ elog "If you are upgrading from a version of libexif older than 0.6.13-r2,"
+ elog "you will need to do the following to rebuild dependencies:"
+ elog "# revdep-rebuild --soname libexif.so.9"
+ elog "# revdep-rebuild --soname libexif.so.10"
+ elog ""
+ elog "Note, it is actually safe to create a symlink from libexif.so.10 to"
+ elog "libexif.so.12 if you need to during the update."
+}
+
diff --git a/media-libs/libexif/libexif-0.6.15.ebuild b/media-libs/libexif/libexif-0.6.15.ebuild
index 7363e376ec4e..8a43ff18504c 100644
--- a/media-libs/libexif/libexif-0.6.15.ebuild
+++ b/media-libs/libexif/libexif-0.6.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.15.ebuild,v 1.7 2007/05/30 20:24:27 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.15.ebuild,v 1.8 2007/06/05 08:39:38 eradicator Exp $
inherit eutils
@@ -27,10 +27,9 @@ src_unpack() {
}
src_compile() {
- local my_conf
- use doc && my_conf="--with-doc-dir=/usr/share/doc/${PF}"
+ local my_conf="--with-doc-dir=/usr/share/doc/${PF}"
use nls || my_conf="${my_conf} --without-libintl-prefix"
- econf $(use_enable nls) $(use_enable doc) \
+ econf $(use_enable nls) $(use_enable doc docs) \
--with-pic --disable-rpath ${my_conf} || die
emake || die
}
@@ -49,3 +48,13 @@ src_install() {
# installs a blank directory for whatever broken reason
use nls || rm -rf ${D}usr/share/locale
}
+
+pkg_postinst() {
+ elog "If you are upgrading from a version of libexif older than 0.6.13-r2,"
+ elog "you will need to do the following to rebuild dependencies:"
+ elog "# revdep-rebuild --soname libexif.so.9"
+ elog "# revdep-rebuild --soname libexif.so.10"
+ elog ""
+ elog "Note, it is actually safe to create a symlink from libexif.so.10 to"
+ elog "libexif.so.12 if you need to during the update."
+}