summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2011-10-10 23:03:33 +0000
committerSteve Dibb <beandog@gentoo.org>2011-10-10 23:03:33 +0000
commit4521e65611333bda90487e8e51f1f58c2aed82ad (patch)
tree92d4de9d044a5b7054afeac510c302359bbeda60 /media-libs/libdvdnav/libdvdnav-4.2.0.ebuild
parentUpdate homepage (diff)
downloadgentoo-2-4521e65611333bda90487e8e51f1f58c2aed82ad.tar.gz
gentoo-2-4521e65611333bda90487e8e51f1f58c2aed82ad.tar.bz2
gentoo-2-4521e65611333bda90487e8e51f1f58c2aed82ad.zip
Move 4.2.0_pre ebuild to release; Fix SRC_URI to use upstream; Update homepage
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libdvdnav/libdvdnav-4.2.0.ebuild')
-rw-r--r--media-libs/libdvdnav/libdvdnav-4.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/libdvdnav/libdvdnav-4.2.0.ebuild b/media-libs/libdvdnav/libdvdnav-4.2.0.ebuild
new file mode 100644
index 000000000000..b0b8d8bcd4ae
--- /dev/null
+++ b/media-libs/libdvdnav/libdvdnav-4.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/libdvdnav-4.2.0.ebuild,v 1.1 2011/10/10 23:03:33 beandog Exp $
+
+EAPI=4
+inherit autotools libtool
+
+DESCRIPTION="Library for DVD navigation tools"
+HOMEPAGE="http://dvdnav.mplayerhq.hu/"
+SRC_URI="http://dvdnav.mplayerhq.hu/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=media-libs/libdvdread-${PV}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog DEVELOPMENT-POLICY.txt doc/dvd_structures NEWS README TODO )
+
+src_prepare() {
+ sed -i -e '/^CFLAGS/s:-O3::' configure.ac || die
+ elibtoolize
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm -f "${ED}"usr/lib*/${PN}*.la
+}