summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-02 21:15:13 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-02 21:15:13 +0000
commit4d07d127ffef4858d37917d6938b2f892b244ed8 (patch)
tree227eff2822f10a7a04d931ca2427058e603ca6fa /media-libs/libchamplain
parentMarked ~x64-macos, bug #333981 (diff)
downloadgentoo-2-4d07d127ffef4858d37917d6938b2f892b244ed8.tar.gz
gentoo-2-4d07d127ffef4858d37917d6938b2f892b244ed8.tar.bz2
gentoo-2-4d07d127ffef4858d37917d6938b2f892b244ed8.zip
Version Bump
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libchamplain')
-rw-r--r--media-libs/libchamplain/ChangeLog7
-rw-r--r--media-libs/libchamplain/libchamplain-0.8.0.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/media-libs/libchamplain/ChangeLog b/media-libs/libchamplain/ChangeLog
index 3443841b8ff7..d9839573a8ce 100644
--- a/media-libs/libchamplain/ChangeLog
+++ b/media-libs/libchamplain/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libchamplain
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libchamplain/ChangeLog,v 1.3 2010/06/22 07:32:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libchamplain/ChangeLog,v 1.4 2010/10/02 21:15:13 jlec Exp $
+
+*libchamplain-0.8.0 (02 Oct 2010)
+
+ 02 Oct 2010; Justin Lecher <jlec@gentoo.org> +libchamplain-0.8.0.ebuild:
+ Version Bump
22 Jun 2010; Justin Lecher <jlec@gentoo.org> libchamplain-0.6.0.ebuild:
Added missing *DEPENDs on media-libs/pymemphis, bug 324673
diff --git a/media-libs/libchamplain/libchamplain-0.8.0.ebuild b/media-libs/libchamplain/libchamplain-0.8.0.ebuild
new file mode 100644
index 000000000000..03263abe0134
--- /dev/null
+++ b/media-libs/libchamplain/libchamplain-0.8.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libchamplain/libchamplain-0.8.0.ebuild,v 1.1 2010/10/02 21:15:13 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit gnome2 python
+
+DESCRIPTION="Clutter based world map renderer"
+HOMEPAGE="http://blog.pierlux.com/projects/libchamplain/en/"
+
+LICENSE="LGPL-2"
+SLOT="0.6"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gtk introspection python"
+
+RDEPEND="
+ >=dev-libs/glib-2.16
+ >=x11-libs/cairo-1.4
+ >=net-libs/libsoup-2.26[gnome]
+ media-libs/clutter:1.0
+ media-libs/memphis
+ dev-db/sqlite:3
+ gtk? (
+ >=x11-libs/gtk+-2.18
+ media-libs/memphis:0.2
+ >=media-libs/clutter-gtk-0.10:1.0 )
+ python? (
+ media-libs/pymemphis
+ dev-python/pyclutter
+ dev-python/pyclutter-gtk )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+G2CONF="${G2CONF}
+ --disable-static
+ --enable-memphis
+ $(use_enable debug)
+ $(use_enable gtk)
+ $(use_enable introspection)
+ $(use_enable python)"
+
+src_prepare() {
+ gnome2_src_prepare
+ sed 's:bindings::g' -i Makefile.in || die
+}
+
+src_compile() {
+ gnome2_src_compile
+ if use python; then
+ python_copy_sources bindings
+ building() {
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pythondir="$(python_get_sitedir)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir bindings building
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+ if use python; then
+ installation() {
+ emake DESTDIR="${ED}" \
+ pythondir="$(python_get_sitedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir bindings installation
+ python_clean_installation_image
+ fi
+}