summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-07-15 20:52:40 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-07-15 20:52:40 +0000
commite4929ca56e17732d1a5590615578955dc1a99fcb (patch)
tree1a4014e187dbea9210186f40fc22bde686fd5f7d /media-libs/ladspa-sdk
parentAdded a modutils fix for HPPA. (Manifest recommit) (diff)
downloadgentoo-2-e4929ca56e17732d1a5590615578955dc1a99fcb.tar.gz
gentoo-2-e4929ca56e17732d1a5590615578955dc1a99fcb.tar.bz2
gentoo-2-e4929ca56e17732d1a5590615578955dc1a99fcb.zip
added LADSPA_PATH env var
Diffstat (limited to 'media-libs/ladspa-sdk')
-rw-r--r--media-libs/ladspa-sdk/ChangeLog6
-rw-r--r--media-libs/ladspa-sdk/Manifest8
-rw-r--r--media-libs/ladspa-sdk/files/digest-ladspa-sdk-1.12-r11
-rw-r--r--media-libs/ladspa-sdk/ladspa-sdk-1.12-r1.ebuild48
4 files changed, 59 insertions, 4 deletions
diff --git a/media-libs/ladspa-sdk/ChangeLog b/media-libs/ladspa-sdk/ChangeLog
index 1f34e351dca1..15c7646bb272 100644
--- a/media-libs/ladspa-sdk/ChangeLog
+++ b/media-libs/ladspa-sdk/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for media-libs/ladspa-sdk
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-sdk/ChangeLog,v 1.15 2004/07/01 08:35:20 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-sdk/ChangeLog,v 1.16 2004/07/15 20:52:40 zypher Exp $
+ 15 Jul 2004; Marc Hildebrand <zypher@gentoo.org>
+ ladspa-sdk-1.12-r1.ebuild:
+ Added LADSPA_PATH=/usr/lib/ladspa (via /etc/env.d/60ladspa)
+
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
ladspa-sdk-1.0.ebuild, ladspa-sdk-1.12.ebuild:
virtual/glibc -> virtual/libc
diff --git a/media-libs/ladspa-sdk/Manifest b/media-libs/ladspa-sdk/Manifest
index 42bd7dacb907..573dd689ac95 100644
--- a/media-libs/ladspa-sdk/Manifest
+++ b/media-libs/ladspa-sdk/Manifest
@@ -1,6 +1,8 @@
MD5 3342f96f62a628923754b3c0e47b1aae ladspa-sdk-1.12.ebuild 1092
-MD5 9cc7d50e449dabaa2ceba35294d62906 ChangeLog 2135
-MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 f02badc426c3a2728834bae1ff9bdcc9 ladspa-sdk-1.0.ebuild 878
-MD5 cac1ad9f78c8b6a13d80cd27413990c6 files/digest-ladspa-sdk-1.12 63
+MD5 720d317fae631096ff7a7543c9febd34 ladspa-sdk-1.12-r1.ebuild 1205
+MD5 8f5a54824cd29e0ed482727baa621795 ChangeLog 2280
+MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 66e1bf2c3d8f56ee85430ef5b52bb5ee files/digest-ladspa-sdk-1.0 58
+MD5 cac1ad9f78c8b6a13d80cd27413990c6 files/digest-ladspa-sdk-1.12-r1 63
+MD5 cac1ad9f78c8b6a13d80cd27413990c6 files/digest-ladspa-sdk-1.12 63
diff --git a/media-libs/ladspa-sdk/files/digest-ladspa-sdk-1.12-r1 b/media-libs/ladspa-sdk/files/digest-ladspa-sdk-1.12-r1
new file mode 100644
index 000000000000..7ee5f9b8c87b
--- /dev/null
+++ b/media-libs/ladspa-sdk/files/digest-ladspa-sdk-1.12-r1
@@ -0,0 +1 @@
+MD5 dbd63dd701d80b152943073c84565c14 ladspa_sdk_1.12.tgz 71165
diff --git a/media-libs/ladspa-sdk/ladspa-sdk-1.12-r1.ebuild b/media-libs/ladspa-sdk/ladspa-sdk-1.12-r1.ebuild
new file mode 100644
index 000000000000..421eb6f5ad87
--- /dev/null
+++ b/media-libs/ladspa-sdk/ladspa-sdk-1.12-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-sdk/ladspa-sdk-1.12-r1.ebuild,v 1.1 2004/07/15 20:52:40 zypher Exp $
+
+IUSE=""
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}_${PV}
+S=${WORKDIR}/${MY_PN}/src
+
+DESCRIPTION="The Linux Audio Developer's Simple Plugin API and some example plugins"
+SRC_URI="http://www.ladspa.org/download/${MY_P}.tgz"
+HOMEPAGE="http://www.ladspa.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="x86 ppc sparc alpha amd64"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e "/^CFLAGS/ s:-O3:${CFLAGS}:" ${S}/makefile || \
+ die "sed makefile failed (CFLAGS)"
+ sed -i s:-mkdirhier:mkdir\ -p:g ${S}/makefile || \
+ die "sed makefile failed (mkdirhier)"
+}
+
+src_compile() {
+ emake targets || die
+}
+
+src_install() {
+ make \
+ INSTALL_PLUGINS_DIR=${D}/usr/lib/ladspa \
+ INSTALL_INCLUDE_DIR=${D}/usr/include \
+ INSTALL_BINARY_DIR=${D}/usr/bin \
+ install || die "make install failed"
+
+ cd ../doc && \
+ dohtml *.html || die "dohtml failed"
+
+ # Needed for apps like rezound
+ dodir /etc/env.d
+ echo "LADSPA_PATH=/usr/lib/ladspa" > ${D}/etc/env.d/60ladspa
+}