summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-22 10:29:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-22 10:29:58 +0000
commit9abe122fccd9d3bd35c8d76d8e8c38fd69ffcffc (patch)
tree0dbee7a875240550065583b79e2f81a6e3bed3a2 /media-libs/jpeg
parentMask media-libs/jpeg-7 for testing. (diff)
downloadgentoo-2-9abe122fccd9d3bd35c8d76d8e8c38fd69ffcffc.tar.gz
gentoo-2-9abe122fccd9d3bd35c8d76d8e8c38fd69ffcffc.tar.bz2
gentoo-2-9abe122fccd9d3bd35c8d76d8e8c38fd69ffcffc.zip
Version bump.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/ChangeLog9
-rw-r--r--media-libs/jpeg/jpeg-7.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index 4c882eba606a..b60bfcf78092 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/jpeg
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.70 2008/08/16 15:49:20 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.71 2009/08/22 10:29:58 ssuominen Exp $
+
+*jpeg-7 (22 Aug 2009)
+
+ 22 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> +jpeg-7.ebuild:
+ Version bump.
16 Aug 2008; Markus Meier <maekke@gentoo.org> -jpeg-6b-r7.ebuild:
old
diff --git a/media-libs/jpeg/jpeg-7.ebuild b/media-libs/jpeg/jpeg-7.ebuild
new file mode 100644
index 000000000000..8aa7f9c24b3b
--- /dev/null
+++ b/media-libs/jpeg/jpeg-7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-7.ebuild,v 1.1 2009/08/22 10:29:58 ssuominen Exp $
+
+EAPI=2
+inherit libtool toolchain-funcs
+
+DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
+HOMEPAGE="http://www.ijg.org/"
+SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz
+ http://dev.gentoo.org/~ssuominen/${P}-extra.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ --enable-static \
+ --enable-maxmem=64
+}
+
+src_compile() {
+ emake || die "emake failed"
+ tc-export CC
+ emake -C "${WORKDIR}"/${P}-extra
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ emake -C "${WORKDIR}"/${P}-extra DESTDIR="${D}" \
+ install || die "install failed"
+
+ dodoc example.c README *.{log,txt} || die "dodoc failed"
+}