summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-01-04 18:03:21 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-01-04 18:03:21 +0000
commit66b547e2cd9efb4bcf246ddfd3a50f7a43ab960b (patch)
tree96587c1138721b6d98ef8cd2702114930e588262 /media-libs/jpeg
parentFixing glibc issues; bug #76626. (Manifest recommit) (diff)
downloadgentoo-2-66b547e2cd9efb4bcf246ddfd3a50f7a43ab960b.tar.gz
gentoo-2-66b547e2cd9efb4bcf246ddfd3a50f7a43ab960b.tar.bz2
gentoo-2-66b547e2cd9efb4bcf246ddfd3a50f7a43ab960b.zip
Solved libtool problem on amd64 and combined with pic patch, bug #75092
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/ChangeLog8
-rw-r--r--media-libs/jpeg/files/jpeg-6b-gentoo.patch24
-rw-r--r--media-libs/jpeg/files/jpeg-6b-pic.patch12
-rw-r--r--media-libs/jpeg/jpeg-6b-r4.ebuild6
4 files changed, 33 insertions, 17 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index 56e441e1622c..7aedb6857ae7 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/jpeg
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.29 2004/11/18 21:27:20 lu_zero Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.30 2005/01/04 18:03:21 sekretarz Exp $
+
+ 04 Jan 2005; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/jpeg-6b-gentoo.patch, -files/jpeg-6b-pic.patch, jpeg-6b-r4.ebuild:
+ Solved libtool problem on amd64 and combined with pic patch, bug #75092
18 Nov 2004; Luca Barbato <lu_zero@gentoo.org> +files/jpeg-6b-pic.patch,
jpeg-6b-r4.ebuild:
diff --git a/media-libs/jpeg/files/jpeg-6b-gentoo.patch b/media-libs/jpeg/files/jpeg-6b-gentoo.patch
new file mode 100644
index 000000000000..d70e4653b693
--- /dev/null
+++ b/media-libs/jpeg/files/jpeg-6b-gentoo.patch
@@ -0,0 +1,24 @@
+diff -Naur jpeg-6b.orig/configure jpeg-6b/configure
+--- jpeg-6b.orig/configure 2005-01-04 15:34:08.000000000 +0100
++++ jpeg-6b/configure 2005-01-04 15:39:10.620128760 +0100
+@@ -1529,7 +1529,7 @@
+
+ if test "x$LTSHARED" != xno -o "x$LTSTATIC" != xno; then
+ USELIBTOOL="yes"
+- LIBTOOL="./libtool"
++ LIBTOOL="libtool"
+ O="lo"
+ A="la"
+ LN='$(LIBTOOL) --mode=link $(CC)'
+diff -Naur jpeg-6b.orig/ltconfig jpeg-6b/ltconfig
+--- jpeg-6b.orig/ltconfig 2005-01-04 15:41:06.025584464 +0100
++++ jpeg-6b/ltconfig 2005-01-04 15:34:08.315086112 +0100
+@@ -553,7 +553,7 @@
+ # On HP-UX, both CC and GCC only warn that PIC is supported... then they
+ # create non-PIC objects. So, if there were any warnings, we assume that
+ # PIC is not supported.
+- if test -s conftest.err; then
++ if test -s conftest.err -a $pic_flag -eq '+Z'; then
+ echo "$ac_t"no 1>&6
+ can_build_shared=no
+ pic_flag=
diff --git a/media-libs/jpeg/files/jpeg-6b-pic.patch b/media-libs/jpeg/files/jpeg-6b-pic.patch
deleted file mode 100644
index a00ed79df1a9..000000000000
--- a/media-libs/jpeg/files/jpeg-6b-pic.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN jpeg-6b.orig/ltconfig jpeg-6b/ltconfig
---- jpeg-6b.orig/ltconfig 2004-11-18 20:37:05.063778128 +0100
-+++ jpeg-6b/ltconfig 2004-11-18 20:32:55.000000000 +0100
-@@ -553,7 +553,7 @@
- # On HP-UX, both CC and GCC only warn that PIC is supported... then they
- # create non-PIC objects. So, if there were any warnings, we assume that
- # PIC is not supported.
-- if test -s conftest.err; then
-+ if test -s conftest.err -a $pic_flag -eq '+Z'; then
- echo "$ac_t"no 1>&6
- can_build_shared=no
- pic_flag=
diff --git a/media-libs/jpeg/jpeg-6b-r4.ebuild b/media-libs/jpeg/jpeg-6b-r4.ebuild
index ecd1a6461670..8f49ca80bdb7 100644
--- a/media-libs/jpeg/jpeg-6b-r4.ebuild
+++ b/media-libs/jpeg/jpeg-6b-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r4.ebuild,v 1.3 2004/12/17 06:27:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r4.ebuild,v 1.4 2005/01/04 18:03:21 sekretarz Exp $
inherit flag-o-matic libtool eutils toolchain-funcs
@@ -26,7 +26,7 @@ src_unpack() {
sed -i 's/ltconfig.*/& $CHOST/' configure
uclibctoolize
use ppc-macos && darwintoolize
- epatch ${FILESDIR}/${P}-pic.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
}
src_compile() {