summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-16 11:39:24 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-16 11:39:24 +0000
commit67bf6ee5c08a2c40db54d9a5b277cf620eb5158b (patch)
tree320f16b192506529c96ea087fd277f8033c9ac80 /media-libs/iulib/iulib-0.4.ebuild
parentMissing inherit flag-o-matic wrt #276142. Remove useless FEATURES="ccache" ch... (diff)
downloadgentoo-2-67bf6ee5c08a2c40db54d9a5b277cf620eb5158b.tar.gz
gentoo-2-67bf6ee5c08a2c40db54d9a5b277cf620eb5158b.tar.bz2
gentoo-2-67bf6ee5c08a2c40db54d9a5b277cf620eb5158b.zip
Version bump #297104 by Michał Górny.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/iulib/iulib-0.4.ebuild')
-rw-r--r--media-libs/iulib/iulib-0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/iulib/iulib-0.4.ebuild b/media-libs/iulib/iulib-0.4.ebuild
new file mode 100644
index 000000000000..318d22e052a1
--- /dev/null
+++ b/media-libs/iulib/iulib-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/iulib/iulib-0.4.ebuild,v 1.1 2009/12/16 11:39:24 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="easy-to-use image and video I/O functions"
+HOMEPAGE="http://code.google.com/p/iulib/"
+SRC_URI="http://iulib.googlecode.com/files/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sdl"
+
+DEPEND="sys-libs/zlib
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ sdl? ( media-libs/libsdl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.4-scons-build-env.patch
+}
+
+src_compile() {
+ tc-export CC CXX
+ scons prefix=/usr || die
+}
+
+src_install() {
+ scons install prefix="${D}/usr" || die
+ dodoc CHANGES README TODO
+}