summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-05-29 04:26:12 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-05-29 04:26:12 +0000
commit4040ea67faa339d4e620030784f33e6f1660d572 (patch)
tree41992c58e54bcb52fe8ffe272b89a111e03c87c7 /media-libs/imlib
parentwavemon is an ncurses wavelan monitoring utility (diff)
downloadgentoo-2-4040ea67faa339d4e620030784f33e6f1660d572.tar.gz
gentoo-2-4040ea67faa339d4e620030784f33e6f1660d572.tar.bz2
gentoo-2-4040ea67faa339d4e620030784f33e6f1660d572.zip
Pass configure --includedir="" and make install
includedir=${D}/usr/include to make gcc3.1 happy (also tested on a 2.95.3 machine).
Diffstat (limited to 'media-libs/imlib')
-rw-r--r--media-libs/imlib/ChangeLog13
-rw-r--r--media-libs/imlib/files/digest-imlib-1.9.14-r11
-rw-r--r--media-libs/imlib/imlib-1.9.14-r1.ebuild49
3 files changed, 62 insertions, 1 deletions
diff --git a/media-libs/imlib/ChangeLog b/media-libs/imlib/ChangeLog
index 93922194c3c0..6baf00a778d4 100644
--- a/media-libs/imlib/ChangeLog
+++ b/media-libs/imlib/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-libs/imlib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib/ChangeLog,v 1.6 2002/05/04 14:53:29 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib/ChangeLog,v 1.7 2002/05/29 04:26:12 mkennedy Exp $
+
+*imlib-1.9.14-r1 (28 May 2002)
+
+ 28 May 2002; Matthew Kennedy <mkennedy@gentoo.org> imlib-1.9.14-r1.ebuild
+ files/digest-imlib-1.9.14-r1, ChangeLog :
+
+ Pass configure --includedir="" and make install
+ includedir=${D}/usr/include to make gcc3.1 happy (also tested on a
+ 2.95.3 machine). Thanks to Rufiao Valhacouto
+ <rufiao@gmx.net> and lostlogic@lostlogicx.com (Brandon Low) of bug
+ #3135 for this nice catch.
*imlib-1.9.14 (4 May 2002)
diff --git a/media-libs/imlib/files/digest-imlib-1.9.14-r1 b/media-libs/imlib/files/digest-imlib-1.9.14-r1
new file mode 100644
index 000000000000..d08237fcf000
--- /dev/null
+++ b/media-libs/imlib/files/digest-imlib-1.9.14-r1
@@ -0,0 +1 @@
+MD5 1fa54011e4e1db532d7eadae3ced6a8c imlib-1.9.14.tar.gz 748591
diff --git a/media-libs/imlib/imlib-1.9.14-r1.ebuild b/media-libs/imlib/imlib-1.9.14-r1.ebuild
new file mode 100644
index 000000000000..90eed975ad9d
--- /dev/null
+++ b/media-libs/imlib/imlib-1.9.14-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib/imlib-1.9.14-r1.ebuild,v 1.1 2002/05/29 04:26:12 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Imlib is a general Image loading and rendering library."
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
+ http://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1.2*
+ >=media-libs/tiff-3.5.5
+ >=media-libs/giflib-4.1.0
+ >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b"
+
+src_compile() {
+
+ #update libtool to fix "relink" bug
+ libtoolize --copy --force
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --includedir="" \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/imlib || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ includedir=${D}/usr/include \
+ sysconfdir=${D}/etc/imlib \
+ install || die
+
+ preplib /usr
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS
+ dohtml -r doc
+}