summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-12-09 00:01:00 +0000
committerJeroen Roovers <jer@gentoo.org>2014-12-09 00:01:00 +0000
commitfca1fbbfffd04e82bacf276883eb8861f3b6a3d7 (patch)
tree2852b24831df0a5d1fde38c9ab72355d4f5c02c0 /media-libs/ilmbase
parentMask gcj-jdk[X] instead of the whole package, pointed out in bug #531900, com... (diff)
downloadgentoo-2-fca1fbbfffd04e82bacf276883eb8861f3b6a3d7.tar.gz
gentoo-2-fca1fbbfffd04e82bacf276883eb8861f3b6a3d7.tar.bz2
gentoo-2-fca1fbbfffd04e82bacf276883eb8861f3b6a3d7.zip
Do not use ucontext on architectures that it does not support (bug #482890).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'media-libs/ilmbase')
-rw-r--r--media-libs/ilmbase/ChangeLog6
-rw-r--r--media-libs/ilmbase/ilmbase-2.1.0.ebuild11
-rw-r--r--media-libs/ilmbase/ilmbase-2.2.0.ebuild11
3 files changed, 25 insertions, 3 deletions
diff --git a/media-libs/ilmbase/ChangeLog b/media-libs/ilmbase/ChangeLog
index 38d6579254fd..f3a11bf8178e 100644
--- a/media-libs/ilmbase/ChangeLog
+++ b/media-libs/ilmbase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/ilmbase
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ChangeLog,v 1.38 2014/08/22 21:56:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ChangeLog,v 1.39 2014/12/09 00:01:00 jer Exp $
+
+ 09 Dec 2014; Jeroen Roovers <jer@gentoo.org> ilmbase-2.1.0.ebuild,
+ ilmbase-2.2.0.ebuild:
+ Do not use ucontext on architectures that it does not support (bug #482890).
*ilmbase-2.2.0 (22 Aug 2014)
diff --git a/media-libs/ilmbase/ilmbase-2.1.0.ebuild b/media-libs/ilmbase/ilmbase-2.1.0.ebuild
index 31ec09b34735..4d110efae463 100644
--- a/media-libs/ilmbase/ilmbase-2.1.0.ebuild
+++ b/media-libs/ilmbase/ilmbase-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ilmbase-2.1.0.ebuild,v 1.2 2014/08/03 19:04:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ilmbase-2.1.0.ebuild,v 1.3 2014/12/09 00:01:00 jer Exp $
EAPI=5
inherit autotools-multilib
@@ -16,3 +16,12 @@ IUSE="static-libs"
DOCS=( AUTHORS ChangeLog NEWS README )
MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/IlmBaseConfig.h )
+
+src_configure() {
+ # Disable use of ucontext.h wrt #482890
+ if use hppa || use ppc || use ppc64; then
+ export ac_cv_header_ucontext_h=no
+ fi
+
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/ilmbase/ilmbase-2.2.0.ebuild b/media-libs/ilmbase/ilmbase-2.2.0.ebuild
index db91c7429ae4..eb74537c9cf3 100644
--- a/media-libs/ilmbase/ilmbase-2.2.0.ebuild
+++ b/media-libs/ilmbase/ilmbase-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ilmbase-2.2.0.ebuild,v 1.2 2014/08/24 05:48:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ilmbase-2.2.0.ebuild,v 1.3 2014/12/09 00:01:00 jer Exp $
EAPI=5
inherit autotools-multilib
@@ -16,3 +16,12 @@ IUSE="static-libs"
DOCS=( AUTHORS ChangeLog NEWS README )
MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/IlmBaseConfig.h )
+
+src_configure() {
+ # Disable use of ucontext.h wrt #482890
+ if use hppa || use ppc || use ppc64; then
+ export ac_cv_header_ucontext_h=no
+ fi
+
+ autotools-multilib_src_configure
+}