summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-11 20:11:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-11 20:11:35 +0000
commita4d4d52bf003e180c5f6dff027518f8f9cd951fc (patch)
treeda5b4b1f4875c06f0b2be8457348c404bcd538df /media-libs/ilmbase
parentRevision bump, move files from /usr/etc/ to /etc/ wrt bug 460760 (diff)
downloadgentoo-2-a4d4d52bf003e180c5f6dff027518f8f9cd951fc.tar.gz
gentoo-2-a4d4d52bf003e180c5f6dff027518f8f9cd951fc.tar.bz2
gentoo-2-a4d4d52bf003e180c5f6dff027518f8f9cd951fc.zip
Version bump.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/ilmbase')
-rw-r--r--media-libs/ilmbase/ChangeLog9
-rw-r--r--media-libs/ilmbase/ilmbase-2.0.0.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/media-libs/ilmbase/ChangeLog b/media-libs/ilmbase/ChangeLog
index 3190ff15bc8f..ede66327b3ed 100644
--- a/media-libs/ilmbase/ChangeLog
+++ b/media-libs/ilmbase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/ilmbase
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ChangeLog,v 1.27 2012/05/09 16:52:21 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ChangeLog,v 1.28 2013/03/11 20:11:35 ssuominen Exp $
+
+*ilmbase-2.0.0 (11 Mar 2013)
+
+ 11 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> +ilmbase-2.0.0.ebuild:
+ Version bump.
09 May 2012; Alexis Ballier <aballier@gentoo.org> ilmbase-1.0.2.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/ilmbase/ilmbase-2.0.0.ebuild b/media-libs/ilmbase/ilmbase-2.0.0.ebuild
new file mode 100644
index 000000000000..411598e8517c
--- /dev/null
+++ b/media-libs/ilmbase/ilmbase-2.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ilmbase/ilmbase-2.0.0.ebuild,v 1.1 2013/03/11 20:11:35 ssuominen Exp $
+
+EAPI=5
+inherit autotools eutils #libtool
+
+DESCRIPTION="OpenEXR ILM Base libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/openexr-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+S=${WORKDIR}/openexr-${PV}/IlmBase
+
+src_prepare() {
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+ eautoreconf
+# elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+ prune_libtool_files
+}