summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-01 13:33:20 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-01 13:33:20 +0000
commitd943b4a7872516a63475d6839a60b0a89f5748e0 (patch)
treeecab4be0fadc6ee88833376ff1be406a4ca3cbef /media-libs/harfbuzz
parentIntroduce multilib support as a dependency of pango, bug #488860. (diff)
downloadgentoo-2-d943b4a7872516a63475d6839a60b0a89f5748e0.tar.gz
gentoo-2-d943b4a7872516a63475d6839a60b0a89f5748e0.tar.bz2
gentoo-2-d943b4a7872516a63475d6839a60b0a89f5748e0.zip
Introduce multilib support as a dependency of pango, bug #488864.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/ChangeLog7
-rw-r--r--media-libs/harfbuzz/harfbuzz-0.9.26-r1.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/media-libs/harfbuzz/ChangeLog b/media-libs/harfbuzz/ChangeLog
index efbbfed1a988..00276c970a89 100644
--- a/media-libs/harfbuzz/ChangeLog
+++ b/media-libs/harfbuzz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/harfbuzz
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.64 2014/02/22 22:22:26 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.65 2014/03/01 13:33:20 mgorny Exp $
+
+*harfbuzz-0.9.26-r1 (01 Mar 2014)
+
+ 01 Mar 2014; Michał Górny <mgorny@gentoo.org> +harfbuzz-0.9.26-r1.ebuild:
+ Introduce multilib support as a dependency of pango, bug #488864.
22 Feb 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
harfbuzz-0.9.23.ebuild, harfbuzz-0.9.26.ebuild, harfbuzz-9999.ebuild:
diff --git a/media-libs/harfbuzz/harfbuzz-0.9.26-r1.ebuild b/media-libs/harfbuzz/harfbuzz-0.9.26-r1.ebuild
new file mode 100644
index 000000000000..6a482d96c8b0
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-0.9.26-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-0.9.26-r1.ebuild,v 1.1 2014/03/01 13:33:20 mgorny Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-2 autotools
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils libtool multilib-minimal python-any-r1
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="http://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="+cairo +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
+ graphite? ( media-gfx/graphite2:=[${MULTILIB_USEDEP}] )
+ icu? ( dev-libs/icu:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34 )
+ truetype? ( media-libs/freetype:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(multilib_is_native_abi \
+ && use_with cairo \
+ || echo --without-cairo) \
+ $(use_with glib) \
+ $(use_with glib gobject) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(multilib_is_native_abi \
+ && use_enable introspection \
+ || echo --disable-introspection) \
+ $(use_with truetype freetype)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --modules
+}