summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2011-12-15 09:01:06 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2011-12-15 09:01:06 +0000
commitb01b1991aa3da4bef79ed4dd6e8482bfe304d367 (patch)
treebe83a66fcddb8041a181c0212077748568388ad7 /media-libs/hamlib
parentRevision bump wrt opts deprecated in initscript (quite annoying to see as use... (diff)
downloadgentoo-2-b01b1991aa3da4bef79ed4dd6e8482bfe304d367.tar.gz
gentoo-2-b01b1991aa3da4bef79ed4dd6e8482bfe304d367.tar.bz2
gentoo-2-b01b1991aa3da4bef79ed4dd6e8482bfe304d367.zip
Use only autotools-utils functions. Bug #392101
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/ChangeLog5
-rw-r--r--media-libs/hamlib/hamlib-1.2.14.ebuild41
2 files changed, 23 insertions, 23 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index b06bd4d18788..2628242895d3 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/hamlib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.61 2011/09/01 18:42:33 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.62 2011/12/15 09:01:06 tomjbe Exp $
+
+ 15 Dec 2011; Thomas Beierlein <tomjbe@gentoo.org> hamlib-1.2.14.ebuild:
+ Use only autotools-utils functions. Bug #392101
*hamlib-1.2.14 (01 Sep 2011)
diff --git a/media-libs/hamlib/hamlib-1.2.14.ebuild b/media-libs/hamlib/hamlib-1.2.14.ebuild
index 462c987a4030..a08e866286c1 100644
--- a/media-libs/hamlib/hamlib-1.2.14.ebuild
+++ b/media-libs/hamlib/hamlib-1.2.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.14.ebuild,v 1.1 2011/09/01 18:42:33 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.14.ebuild,v 1.2 2011/12/15 09:01:06 tomjbe Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -29,6 +29,8 @@ DEPEND=" ${RDEPEND}
>=sys-devel/libtool-2.2
doc? ( app-doc/doxygen )"
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer TODO)
+
pkg_setup() {
if use python; then
python_set_active_version 2
@@ -42,6 +44,9 @@ src_prepare() {
-e "s#fix}/include#fix}/include/hamlib#" \
hamlib.pc.in || die "sed failed"
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
# fix tcl lib path
epatch "${FILESDIR}"/${PN}-1.2.11-bindings.diff
@@ -49,36 +54,28 @@ src_prepare() {
}
src_configure() {
- econf \
- --libdir=/usr/$(get_libdir)/hamlib \
- --disable-static \
- --with-rpc-backends \
- --without-perl-binding \
- $(use_with python python-binding) \
+ local myeconfargs=(
+ --libdir=/usr/$(get_libdir)/hamlib
+ --disable-static
+ --with-rpc-backends
+ --without-perl-binding
+ $(use_with python python-binding)
$(use_enable tcl tcl-binding)
+ )
+ autotools-utils_src_configure
}
src_compile() {
- emake || die "emake failed"
-
- if use doc ; then
- cd doc && make doc || die "make doc failed"
- fi
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- remove_libtool_files all
-
- dodoc AUTHORS NEWS PLAN README README.betatester \
- README.developer TODO || die "dodoc failed"
-
- if use doc; then
- dohtml doc/html/* || die "dohtml failed"
- fi
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/html/")
+ autotools-utils_src_install
insinto /usr/$(get_libdir)/pkgconfig
- doins hamlib.pc || die "doins failed"
+ doins "${AUTOTOOLS_BUILD_DIR}"/hamlib.pc || die "doins failed"
echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
doenvd "${T}"/73hamlib || die "doenvd failed"