summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-06-16 23:01:40 +0000
committerAnant Narayanan <anant@gentoo.org>2007-06-16 23:01:40 +0000
commitaab4ddabd870b909b0dd8a3feee69c546a3ae1ad (patch)
tree3f2c0f65fb6de0a564d663203f5aca031d38eb88 /media-libs/hamlib
parentSparc stable --- Bug #182244 --- Runs tests and installs fine. (diff)
downloadgentoo-2-aab4ddabd870b909b0dd8a3feee69c546a3ae1ad.tar.gz
gentoo-2-aab4ddabd870b909b0dd8a3feee69c546a3ae1ad.tar.bz2
gentoo-2-aab4ddabd870b909b0dd8a3feee69c546a3ae1ad.zip
vBump to 1.2.6.1, close bug #178994
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/ChangeLog7
-rw-r--r--media-libs/hamlib/files/digest-hamlib-1.2.6.13
-rw-r--r--media-libs/hamlib/hamlib-1.2.6.1.ebuild77
3 files changed, 86 insertions, 1 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index 4f2b58d02f03..e60998e51fd3 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/hamlib
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.21 2007/04/11 19:14:28 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.22 2007/06/16 23:01:39 anant Exp $
+
+*hamlib-1.2.6.1 (16 Jun 2007)
+
+ 16 Jun 2007; Anant Narayanan <anant@gentoo.org> +hamlib-1.2.6.1.ebuild:
+ vBump to 1.2.6.1, close bug #178994
11 Apr 2007; Christian Heim <phreak@gentoo.org> hamlib-1.2.4.ebuild,
hamlib-1.2.5.ebuild:
diff --git a/media-libs/hamlib/files/digest-hamlib-1.2.6.1 b/media-libs/hamlib/files/digest-hamlib-1.2.6.1
new file mode 100644
index 000000000000..235db686fc34
--- /dev/null
+++ b/media-libs/hamlib/files/digest-hamlib-1.2.6.1
@@ -0,0 +1,3 @@
+MD5 c4aef5fb5060fd3b2d5c18b5fad4506f hamlib-1.2.6.1.tar.gz 1474242
+RMD160 177b9ac3454edac5ceeb0794b4d2215253aaa665 hamlib-1.2.6.1.tar.gz 1474242
+SHA256 a70d54ee60f26ba8b5c183cf1c140cc1ebbcb10640b04aad03a297830e0c6293 hamlib-1.2.6.1.tar.gz 1474242
diff --git a/media-libs/hamlib/hamlib-1.2.6.1.ebuild b/media-libs/hamlib/hamlib-1.2.6.1.ebuild
new file mode 100644
index 000000000000..9683c28c3c83
--- /dev/null
+++ b/media-libs/hamlib/hamlib-1.2.6.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.6.1.ebuild,v 1.1 2007/06/16 23:01:39 anant Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://hamlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="doc gd python tk X"
+
+RESTRICT="test"
+
+RDEPEND="virtual/libc
+ gd? ( media-libs/gd )
+ python? ( dev-lang/python
+ dev-lang/tcl )
+ tk? ( dev-lang/tk )"
+DEPEND=">=sys-devel/libtool-1.5
+ >=sys-devel/autoconf-2.54
+ >=sys-devel/automake-1.7
+ >=dev-util/pkgconfig-0.15
+ >=dev-lang/swig-1.3.14
+ dev-libs/libxml2
+ doc? ( >=app-doc/doxygen-1.3.5 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-pkgconfig-fix.diff || \
+ die "epatch failed"
+}
+
+src_compile() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-microtune \
+ --without-rpc-backends \
+ --without-perl-binding \
+ $(use_with python python-binding) \
+ $(use_with tk tcl-binding) \
+ $(use_with gd rigmatrix) \
+ $(use_with X x) \
+ || die "configure failed"
+
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd doc && make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ einstall \
+ libdir="${D}"/usr/$(get_libdir)/hamlib || \
+ die "einstall failed"
+
+ dodoc AUTHORS PLAN README README.betatester \
+ README.developer LICENSE NEWS TODO
+
+ if use doc; then
+ dohtml doc/html/*
+ doman doc/man/man3/*
+ fi
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+}