summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-28 21:45:42 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-28 21:45:42 +0000
commit2ca2681b60c2d463726efad4aef1d795d562cc2b (patch)
tree77d43c30344d6c596673f7d55b8b814acdb0524c /media-libs/hamlib
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-2ca2681b60c2d463726efad4aef1d795d562cc2b.tar.gz
gentoo-2-2ca2681b60c2d463726efad4aef1d795d562cc2b.tar.bz2
gentoo-2-2ca2681b60c2d463726efad4aef1d795d562cc2b.zip
fix use invocation, glibc -> libc
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/ChangeLog6
-rw-r--r--media-libs/hamlib/hamlib-1.1.4.ebuild10
-rw-r--r--media-libs/hamlib/hamlib-1.2.1.ebuild8
3 files changed, 14 insertions, 10 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index 4d939b2ecb0e..942e651fe1e2 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/hamlib
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.5 2004/06/28 21:35:24 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.6 2004/06/28 21:45:42 agriffis Exp $
+
+ 28 Jun 2004; Aron Griffis <agriffis@gentoo.org> hamlib-1.1.4.ebuild,
+ hamlib-1.2.1.ebuild:
+ fix use invocation, glibc -> libc
28 Jun 2004; David Holm <dholm@gentoo.org> hamlib-1.2.1.ebuild:
Added to ~ppc.
diff --git a/media-libs/hamlib/hamlib-1.1.4.ebuild b/media-libs/hamlib/hamlib-1.1.4.ebuild
index 567de23d7f37..a288b57c61b2 100644
--- a/media-libs/hamlib/hamlib-1.1.4.ebuild
+++ b/media-libs/hamlib/hamlib-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.1.4.ebuild,v 1.2 2004/06/24 23:02:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.1.4.ebuild,v 1.3 2004/06/28 21:45:42 agriffis Exp $
inherit eutils
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~x86 ~alpha"
IUSE="doc gd X"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
X? ( virtual/x11 )
gd? ( media-libs/libgd )"
@@ -41,7 +41,7 @@ src_compile() {
$(use_with X x) \
|| die "configure failed"
emake || die "emake failed"
- if [ -n "$(use doc)" ] ; then
+ if use doc ; then
cd doc && make doc || die "make doc failed"
fi
}
@@ -53,7 +53,7 @@ src_install() {
die "einstall failed"
dodoc AUTHORS PLAN README README.betatester
dodoc README.developer LICENSE NEWS TODO
- if [ -n "$(use doc)" ]; then
+ if use doc; then
dohtml doc/html/*
doman doc/man/man3/*
fi
@@ -62,7 +62,7 @@ src_install() {
}
pkg_postinst() {
- if [ ! -n "$(use gd)" ] ; then
+ if ! use gd ; then
echo
ewarn "Your USE flags do not contain \"gd\"."
ewarn "Therefore, hamlib has been built without"
diff --git a/media-libs/hamlib/hamlib-1.2.1.ebuild b/media-libs/hamlib/hamlib-1.2.1.ebuild
index 814c37866590..5c0e78eda59e 100644
--- a/media-libs/hamlib/hamlib-1.2.1.ebuild
+++ b/media-libs/hamlib/hamlib-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.1.ebuild,v 1.4 2004/06/28 21:35:24 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.1.ebuild,v 1.5 2004/06/28 21:45:42 agriffis Exp $
inherit eutils
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~x86 ~alpha ~ppc"
IUSE="doc gd X"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
X? ( virtual/x11 )
gd? ( media-libs/libgd )"
@@ -40,7 +40,7 @@ src_compile() {
$(use_with X x) \
|| die "configure failed"
emake || die "emake failed"
- if [ -n "$(use doc)" ] ; then
+ if use doc ; then
cd doc && make doc || die "make doc failed"
fi
}
@@ -51,7 +51,7 @@ src_install() {
die "einstall failed"
dodoc AUTHORS PLAN README README.betatester
dodoc README.developer LICENSE NEWS TODO
- if [ -n "$(use doc)" ]; then
+ if use doc; then
dohtml doc/html/*
doman doc/man/man3/*
fi