summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-22 19:18:52 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-22 19:18:52 +0000
commit1f362f024be70372978d44f2c8f1aea1e6fa2f87 (patch)
treedc8535d3142c1704e46e71df1f8af87d5e7b90ed /media-libs/hamlib
parentadded warning regarding force-hints (diff)
downloadgentoo-2-1f362f024be70372978d44f2c8f1aea1e6fa2f87.tar.gz
gentoo-2-1f362f024be70372978d44f2c8f1aea1e6fa2f87.tar.bz2
gentoo-2-1f362f024be70372978d44f2c8f1aea1e6fa2f87.zip
Call some functions from python.eclass only with USE="python".
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/hamlib-1.2.12-r2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/media-libs/hamlib/hamlib-1.2.12-r2.ebuild b/media-libs/hamlib/hamlib-1.2.12-r2.ebuild
index ebff97678442..8c3d8e56bb54 100644
--- a/media-libs/hamlib/hamlib-1.2.12-r2.ebuild
+++ b/media-libs/hamlib/hamlib-1.2.12-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.12-r2.ebuild,v 1.2 2010/12/22 18:47:32 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.12-r2.ebuild,v 1.3 2010/12/22 19:18:52 arfrever Exp $
EAPI="2"
PYTHON_DEPEND="python? 2"
@@ -30,7 +30,10 @@ DEPEND=" ${RDEPEND}
doc? ( app-doc/doxygen )"
pkg_setup() {
- python_set_active_version 2
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -86,5 +89,5 @@ pkg_postinst() {
}
pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/Hamlib.py
+ use python && python_mod_cleanup $(python_get_sitedir)/Hamlib.py
}