summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-10 14:45:12 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-10 14:45:12 +0000
commitd580d1e4449b2adc7fa88f2a17f55a168e5bc83e (patch)
tree45d2c22e5236f9b9a6395e917964b73dca1269fb /media-libs/hamlib/hamlib-1.2.7.1.ebuild
parentdev-cpp/cairomm: bump to 1.6.0 (diff)
downloadgentoo-2-d580d1e4449b2adc7fa88f2a17f55a168e5bc83e.tar.gz
gentoo-2-d580d1e4449b2adc7fa88f2a17f55a168e5bc83e.tar.bz2
gentoo-2-d580d1e4449b2adc7fa88f2a17f55a168e5bc83e.zip
Version bump from Sunrise's portage-review. Remove unnecessary USE flag X and gd, since rigmatrix doesn't get built. Thanks to Thomas Beierlein wrt #219057.
(Portage version: 2.1.5.4)
Diffstat (limited to 'media-libs/hamlib/hamlib-1.2.7.1.ebuild')
-rw-r--r--media-libs/hamlib/hamlib-1.2.7.1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/hamlib/hamlib-1.2.7.1.ebuild b/media-libs/hamlib/hamlib-1.2.7.1.ebuild
new file mode 100644
index 000000000000..76088d7ea010
--- /dev/null
+++ b/media-libs/hamlib/hamlib-1.2.7.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.7.1.ebuild,v 1.1 2008/06/10 14:45:12 drac Exp $
+
+inherit eutils multilib libtool
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://hamlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc python tcl"
+
+RESTRICT="test"
+
+RDEPEND="virtual/libc
+ python? ( dev-lang/python
+ dev-lang/tcl )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND=" ${RDEPEND}
+ >=sys-devel/libtool-1.5
+ >=dev-util/pkgconfig-0.15
+ >=dev-lang/swig-1.3.14
+ dev-libs/libxml2
+ doc? ( >=app-doc/doxygen-1.3.5 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-pkgconfig-fix.diff
+
+ # Needed for FreeBSD - Please do not remove
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-microtune \
+ --without-rpc-backends \
+ --without-perl-binding \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd doc && make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ einstall \
+ libdir="${D}"/usr/$(get_libdir)/hamlib || \
+ die "einstall failed"
+
+ dodoc AUTHORS PLAN README README.betatester \
+ README.developer LICENSE NEWS TODO
+
+ if use doc; then
+ dohtml doc/html/*
+ doman doc/man/man3/*
+ fi
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+}