summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2006-10-06 16:29:31 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2006-10-06 16:29:31 +0000
commitcac684ed18a6925862b2d966c41901b1f91c7e92 (patch)
treec8c1ead251fa7929ea167b90665eba772962d9fc /media-libs/gst-plugins-ugly
parentAdded patch for saving by Pekka Rousu <prousu@users.sourceforge.net>. Closin... (diff)
downloadgentoo-2-cac684ed18a6925862b2d966c41901b1f91c7e92.tar.gz
gentoo-2-cac684ed18a6925862b2d966c41901b1f91c7e92.tar.bz2
gentoo-2-cac684ed18a6925862b2d966c41901b1f91c7e92.zip
version bump
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/files/digest-gst-plugins-ugly-0.10.43
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.4.ebuild78
2 files changed, 81 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/files/digest-gst-plugins-ugly-0.10.4 b/media-libs/gst-plugins-ugly/files/digest-gst-plugins-ugly-0.10.4
new file mode 100644
index 000000000000..aebedd2db84a
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/files/digest-gst-plugins-ugly-0.10.4
@@ -0,0 +1,3 @@
+MD5 c10f40e3641d827ca7853b0a3d560257 gst-plugins-ugly-0.10.4.tar.bz2 720893
+RMD160 0651853d7d36bda9d267ca3cecfb6cead95a3e6e gst-plugins-ugly-0.10.4.tar.bz2 720893
+SHA256 4871c52b2421b582330a0f9dc6a42da3b706140c346aa0cd690eb40758afe152 gst-plugins-ugly-0.10.4.tar.bz2 720893
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.4.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.4.ebuild
new file mode 100644
index 000000000000..72ce70fab22c
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.4.ebuild,v 1.1 2006/10/06 16:29:31 zaheerm Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-ugly gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+#IUSE="esd alsa oss"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.3
+ >=media-libs/gstreamer-0.10.3
+ >=dev-libs/liboil-0.3.0
+ >=dev-libs/glib-2.6.0"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+GST_PLUGINS_BUILD=""
+
+# overrides the eclass
+src_unpack() {
+
+ unpack ${A}
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins-ugly_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide the basic plugins needed."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+
+}