summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-03-30 04:41:56 +0000
committerOlivier Crête <tester@gentoo.org>2009-03-30 04:41:56 +0000
commit2b2649a6948adf65c5666ddf276e85874af1e803 (patch)
treedadf5d5e80dc30443261f61cb88441160cf12d0e /media-libs/gst-plugins-ugly
parentVersion bump (diff)
downloadgentoo-2-2b2649a6948adf65c5666ddf276e85874af1e803.tar.gz
gentoo-2-2b2649a6948adf65c5666ddf276e85874af1e803.tar.bz2
gentoo-2-2b2649a6948adf65c5666ddf276e85874af1e803.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/ChangeLog10
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.11.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/media-libs/gst-plugins-ugly/ChangeLog b/media-libs/gst-plugins-ugly/ChangeLog
index 1a13a31b8a1b..7daaf2938f52 100644
--- a/media-libs/gst-plugins-ugly/ChangeLog
+++ b/media-libs/gst-plugins-ugly/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-ugly
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.47 2008/12/05 22:02:25 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.48 2009/03/30 04:41:56 tester Exp $
+
+*gst-plugins-ugly-0.10.11 (30 Mar 2009)
+
+ 30 Mar 2009; Olivier Crête <tester@gentoo.org>
+ +gst-plugins-ugly-0.10.11.ebuild:
+ Version bump
*gst-plugins-ugly-0.10.10 (05 Dec 2008)
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.11.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.11.ebuild
new file mode 100644
index 000000000000..04416aa5c8b5
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.11.ebuild,v 1.1 2009/03/30 04:41:56 tester Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-ugly gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.22
+ >=media-libs/gstreamer-0.10.22
+ >=dev-libs/liboil-0.3.8
+ >=dev-libs/glib-2.12"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.11"
+
+GST_PLUGINS_BUILD=""
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-ugly_src_configure
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ elog ""
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}