summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2014-12-30 21:46:43 +0000
committerMart Raudsepp <leio@gentoo.org>2014-12-30 21:46:43 +0000
commitb00a03b28eb6a6dcfafc70be86c473fcfbdd7322 (patch)
tree01598af45645e0c5f4b789c62c35bed4c2e27521 /media-libs/gst-plugins-good
parentprovide systemd service files, bug #529192 (diff)
downloadgentoo-2-b00a03b28eb6a6dcfafc70be86c473fcfbdd7322.tar.gz
gentoo-2-b00a03b28eb6a6dcfafc70be86c473fcfbdd7322.tar.bz2
gentoo-2-b00a03b28eb6a6dcfafc70be86c473fcfbdd7322.zip
Version bump. Many updates since 1.2.x series as this is a many months overdue next stable cycle upgrade. Includes new rtpstreampay, rtpstreamdepay and rtprtx* RTP elements.
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog11
-rw-r--r--media-libs/gst-plugins-good/files/gst-plugins-good-1.4.5-rtp-test-fixes.patch98
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.4.5.ebuild (renamed from media-libs/gst-plugins-good/gst-plugins-good-1.2.4.ebuild)42
3 files changed, 133 insertions, 18 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index 214b828c970f..fd745be06bac 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/gst-plugins-good
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.198 2014/10/11 12:43:04 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.199 2014/12/30 21:46:43 leio Exp $
+
+*gst-plugins-good-1.4.5 (30 Dec 2014)
+
+ 30 Dec 2014; Mart Raudsepp <leio@gentoo.org> -gst-plugins-good-1.2.4.ebuild,
+ +gst-plugins-good-1.4.5.ebuild,
+ +files/gst-plugins-good-1.4.5-rtp-test-fixes.patch:
+ Version bump. Many updates since 1.2.x series as this is a many months
+ overdue next stable cycle upgrade. Includes new rtpstreampay, rtpstreamdepay
+ and rtprtx* RTP elements.
11 Oct 2014; Markus Meier <maekke@gentoo.org>
gst-plugins-good-0.10.31-r1.ebuild:
diff --git a/media-libs/gst-plugins-good/files/gst-plugins-good-1.4.5-rtp-test-fixes.patch b/media-libs/gst-plugins-good/files/gst-plugins-good-1.4.5-rtp-test-fixes.patch
new file mode 100644
index 000000000000..08f49f396476
--- /dev/null
+++ b/media-libs/gst-plugins-good/files/gst-plugins-good-1.4.5-rtp-test-fixes.patch
@@ -0,0 +1,98 @@
+Upstream commits d416336 and d67da4c
+
+diff --git a/tests/check/elements/rtpaux.c b/tests/check/elements/rtpaux.c
+index 1f410bf..729604a 100644
+--- a/tests/check/elements/rtpaux.c
++++ b/tests/check/elements/rtpaux.c
+@@ -218,8 +218,8 @@ GST_START_TEST (test_simple_rtpbin_aux)
+ rtpbinsend = gst_element_factory_make ("rtpbin", "rtpbinsend");
+ g_object_set (rtpbinsend, "latency", 200, "do-retransmission", TRUE, NULL);
+ src = gst_element_factory_make ("audiotestsrc", "src");
+- encoder = gst_element_factory_make ("speexenc", "encoder");
+- rtppayloader = gst_element_factory_make ("rtpspeexpay", "rtppayloader");
++ encoder = gst_element_factory_make ("alawenc", "encoder");
++ rtppayloader = gst_element_factory_make ("rtppcmapay", "rtppayloader");
+ rtprtxsend = gst_element_factory_make ("rtprtxsend", "rtprtxsend");
+ sendrtp_udpsink = gst_element_factory_make ("udpsink", "sendrtp_udpsink");
+ g_object_set (sendrtp_udpsink, "host", "127.0.0.1", NULL);
+@@ -238,7 +238,7 @@ GST_START_TEST (test_simple_rtpbin_aux)
+ g_object_set (recvrtp_udpsrc, "port", 5006, NULL);
+ rtpcaps =
+ gst_caps_from_string
+- ("application/x-rtp,media=(string)audio,clock-rate=(int)8000,encoding-name=(string)SPEEX,encoding-params=(string)1,octet-align=(string)1");
++ ("application/x-rtp,media=(string)audio,clock-rate=(int)8000,encoding-name=(string)PCMA,payload=(int)8");
+ g_object_set (recvrtp_udpsrc, "caps", rtpcaps, NULL);
+ gst_caps_unref (rtpcaps);
+ recvrtcp_udpsrc = gst_element_factory_make ("udpsrc", "recvrtcp_udpsrc");
+@@ -249,8 +249,8 @@ GST_START_TEST (test_simple_rtpbin_aux)
+ g_object_set (recvrtcp_udpsink, "sync", FALSE, NULL);
+ g_object_set (recvrtcp_udpsink, "async", FALSE, NULL);
+ rtprtxreceive = gst_element_factory_make ("rtprtxreceive", "rtprtxreceive");
+- rtpdepayloader = gst_element_factory_make ("rtpspeexdepay", "rtpdepayloader");
+- decoder = gst_element_factory_make ("speexdec", "decoder");
++ rtpdepayloader = gst_element_factory_make ("rtppcmadepay", "rtpdepayloader");
++ decoder = gst_element_factory_make ("alawdec", "decoder");
+ converter = gst_element_factory_make ("identity", "converter");
+ sink = gst_element_factory_make ("fakesink", "sink");
+ g_object_set (sink, "sync", TRUE, NULL);
+diff --git a/tests/check/elements/rtpcollision.c b/tests/check/elements/rtpcollision.c
+index e9528f9..16f665f 100644
+--- a/tests/check/elements/rtpcollision.c
++++ b/tests/check/elements/rtpcollision.c
+@@ -156,7 +156,7 @@ fake_udp_sink_chain_func (GstPad * pad, GstObject * parent, GstBuffer * buffer)
+ return GST_FLOW_OK;
+ }
+
+-/* This test build the pipeline audiotestsrc ! speexenc ! rtpspeexpay ! \
++/* This test build the pipeline audiotestsrc ! alawenc ! rtppcmapay ! \
+ * rtpsession ! fakesink
+ * It manually pushs buffer into rtpsession with same ssrc but different
+ * ip so that collision can be detected
+@@ -186,9 +186,9 @@ GST_START_TEST (test_master_ssrc_collision)
+
+ src = gst_element_factory_make ("audiotestsrc", "src");
+ g_object_set (src, "num-buffers", 5, NULL);
+- encoder = gst_element_factory_make ("speexenc", NULL);
+- rtppayloader = gst_element_factory_make ("rtpspeexpay", NULL);
+- g_object_set (rtppayloader, "pt", 96, NULL);
++ encoder = gst_element_factory_make ("alawenc", NULL);
++ rtppayloader = gst_element_factory_make ("rtppcmapay", NULL);
++ g_object_set (rtppayloader, "pt", 8, NULL);
+ rtpsession = gst_element_factory_make ("rtpsession", NULL);
+ sink = gst_element_factory_make ("fakesink", "sink");
+ gst_bin_add_many (GST_BIN (bin), src, encoder, rtppayloader,
+@@ -261,7 +261,7 @@ GST_START_TEST (test_master_ssrc_collision)
+ gst_object_unref (bin);
+
+ /* check results */
+- fail_unless_equals_int (nb_ssrc_changes, 7);
++ fail_unless_equals_int (nb_ssrc_changes, 4);
+ }
+
+ GST_END_TEST;
+@@ -325,7 +325,7 @@ rtpsession_sinkpad_probe2 (GstPad * pad, GstPadProbeInfo * info,
+ return ret;
+ }
+
+-/* This test build the pipeline audiotestsrc ! speexenc ! rtpspeexpay ! \
++/* This test build the pipeline audiotestsrc ! alawenc ! rtppcmapay ! \
+ * rtprtxsend ! rtpsession ! fakesink
+ * It manually pushs buffer into rtpsession with same ssrc than rtx stream
+ * but different ip so that collision can be detected
+@@ -355,12 +355,12 @@ GST_START_TEST (test_rtx_ssrc_collision)
+
+ src = gst_element_factory_make ("audiotestsrc", "src");
+ g_object_set (src, "num-buffers", 5, NULL);
+- encoder = gst_element_factory_make ("speexenc", NULL);
+- rtppayloader = gst_element_factory_make ("rtpspeexpay", NULL);
+- g_object_set (rtppayloader, "pt", 96, NULL);
++ encoder = gst_element_factory_make ("alawenc", NULL);
++ rtppayloader = gst_element_factory_make ("rtppcmapay", NULL);
++ g_object_set (rtppayloader, "pt", 8, NULL);
+ rtprtxsend = gst_element_factory_make ("rtprtxsend", NULL);
+ pt_map = gst_structure_new ("application/x-rtp-pt-map",
+- "96", G_TYPE_UINT, 99, NULL);
++ "8", G_TYPE_UINT, 99, NULL);
+ g_object_set (rtprtxsend, "payload-type-map", pt_map, NULL);
+ gst_structure_free (pt_map);
+ rtpsession = gst_element_factory_make ("rtpsession", NULL);
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.2.4.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.4.5.ebuild
index 166c9a8b0c19..2cee84b1980a 100644
--- a/media-libs/gst-plugins-good/gst-plugins-good-1.2.4.ebuild
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.4.5.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-1.2.4.ebuild,v 1.1 2014/05/31 14:08:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-1.4.5.ebuild,v 1.1 2014/12/30 21:46:43 leio Exp $
EAPI="5"
-# order is important, gst-plugins10 after gst-plugins-good
-inherit eutils flag-o-matic gst-plugins-good gst-plugins10
+GST_ORG_MODULE="gst-plugins-good"
+inherit eutils flag-o-matic gstreamer
-DESCRIPTION="Basepack of plugins for gstreamer"
+DESCRIPTION="Basepack of plugins for GStreamer"
HOMEPAGE="http://gstreamer.freedesktop.org/"
LICENSE="LGPL-2.1+"
@@ -16,30 +16,42 @@ IUSE="+orc"
# dtmf plugin moved from bad to good in 1.2
RDEPEND="
- >=dev-libs/glib-2.32:2
- >=media-libs/gst-plugins-base-1.2.3:${SLOT}
- >=media-libs/gstreamer-1.2.4:${SLOT}
- app-arch/bzip2
- sys-libs/zlib
- orc? ( >=dev-lang/orc-0.4.17 )
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
!<media-libs/gst-plugins-bad-1.1:${SLOT}
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.12
+ sys-apps/sed
"
+src_prepare() {
+ # video coders subtest uses jpeg and png unconditionally; fixed upstream, check on bump, remove sys-apps/sed bdep
+ sed -e '/tcase_add_test.*test_video_encoders_decoders/d' -i "${S}"/tests/check/pipelines/simple-launch-lines.c || die
+
+ epatch "${FILESDIR}/${P}-rtp-test-fixes.patch"
+}
+
src_configure() {
# gst doesnt handle optimisations well
strip-flags
replace-flags "-O3" "-O2"
filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# Always enable optional bz2 support for matroska
# Always enable optional zlib support for qtdemux and matroska
# Many media files require these to work, as some container headers are often
# compressed, bug #291154
- gst-plugins10_src_configure \
+ gstreamer_multilib_src_configure \
--enable-bz2 \
--enable-zlib \
--disable-examples \
@@ -47,12 +59,8 @@ src_configure() {
--with-default-visualizer=goom
}
-src_compile() {
- default
-}
-
-src_install() {
+multilib_src_install_all() {
DOCS="AUTHORS ChangeLog NEWS README RELEASE"
- default
+ einstalldocs
prune_libtool_files --modules
}