summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-06-30 13:08:44 +0000
committerMart Raudsepp <leio@gentoo.org>2011-06-30 13:08:44 +0000
commit57e86648fafeedad098af4dd6d5df7d9db8a555d (patch)
treeeaababd17c270523df9793dbb41fced16f7b66c6 /media-libs/gst-plugins-base
parentDepend on net-im/pidgin[gtk], bug #373049 thank Piotr Szymaniak. (diff)
downloadgentoo-2-57e86648fafeedad098af4dd6d5df7d9db8a555d.tar.gz
gentoo-2-57e86648fafeedad098af4dd6d5df7d9db8a555d.tar.bz2
gentoo-2-57e86648fafeedad098af4dd6d5df7d9db8a555d.zip
Version bump. Don't let the upstream build system always pass -g (honoring CFLAGS in make.conf about it instead), also removed the debug USE flag, which affected nothing. Adds ARGB64, AYUV64 (16 bits per channel) and r210 (10 bits per channel) format support to some elements. Many other improvements, some new API and bug fixes
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-base')
-rw-r--r--media-libs/gst-plugins-base/ChangeLog12
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.35.ebuild54
2 files changed, 65 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-base/ChangeLog b/media-libs/gst-plugins-base/ChangeLog
index 19208580eb82..5f719b1cdc0a 100644
--- a/media-libs/gst-plugins-base/ChangeLog
+++ b/media-libs/gst-plugins-base/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-libs/gst-plugins-base
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.170 2011/06/09 16:01:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.171 2011/06/30 13:08:44 leio Exp $
+
+*gst-plugins-base-0.10.35 (30 Jun 2011)
+
+ 30 Jun 2011; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-base-0.10.35.ebuild:
+ Version bump. Don't let the upstream build system always pass -g (honoring
+ CFLAGS in make.conf about it instead), also removed the debug USE flag,
+ which affected nothing. Adds ARGB64, AYUV64 (16 bits per channel) and r210
+ (10 bits per channel) format support to some elements. Many other
+ improvements, some new API and bug fixes
09 Jun 2011; Jeroen Roovers <jer@gentoo.org> gst-plugins-base-0.10.32.ebuild:
Stable for HPPA (bug #368281).
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.35.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.35.ebuild
new file mode 100644
index 000000000000..7bfb582cc6b3
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.35.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.35.ebuild,v 1.1 2011/06/30 13:08:44 leio Exp $
+
+EAPI=1
+GCONF_DEBUG="no"
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-base gst-plugins10 gnome2 flag-o-matic eutils
+# libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~sparc-solaris ~x64-macos ~x64-solaris ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+introspection nls +orc"
+
+RDEPEND=">=dev-libs/glib-2.22
+ >=media-libs/gstreamer-0.10.34
+ dev-libs/libxml2
+ app-text/iso-codes
+ orc? ( >=dev-lang/orc-0.4.11 )
+ !<media-libs/gst-plugins-bad-0.10.10"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ dev-util/pkgconfig"
+ # Only if running eautoreconf: dev-util/gtk-doc-am
+
+GST_PLUGINS_BUILD=""
+
+DOCS="AUTHORS NEWS README RELEASE"
+
+src_compile() {
+ # gst doesnt handle opts well, last tested with 0.10.15
+ strip-flags
+ replace-flags "-O3" "-O2"
+
+ # Avoid sandbox violation with USE="introspection", bug #356283
+ export GST_REGISTRY=${T}/registry.cache.xml
+
+ gst-plugins-base_src_configure \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable orc) \
+ --disable-examples \
+ --disable-debug
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}