summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2010-07-30 10:11:28 +0000
committerMart Raudsepp <leio@gentoo.org>2010-07-30 10:11:28 +0000
commita818ad0f78d27545bd7987fd3aabde08e5dc569d (patch)
tree8deac73105c7dd129dcbd61c36fecdec446c02ce /media-libs/gst-plugins-bad
parentStable on amd64 wrt bug #329847 (diff)
downloadgentoo-2-a818ad0f78d27545bd7987fd3aabde08e5dc569d.tar.gz
gentoo-2-a818ad0f78d27545bd7987fd3aabde08e5dc569d.tar.bz2
gentoo-2-a818ad0f78d27545bd7987fd3aabde08e5dc569d.zip
Version bump with the following most noteworthy upstream changes: New invtelecine plugin - detects and reconstructs progressive content from telecine video. New segmentclip plugin - add audio/video buffer segment clip elements. Capssetter element has moved to gst-plugins-good-0.10.23+. Bitrate calculation and estimation for audioparsers and mpegvideoparse. Support for muxing VP8 video codec and XMP tags into quicktime video with qtmux. Various new API and properties for camerabin. Many other bug fixes and improvements.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-bad')
-rw-r--r--media-libs/gst-plugins-bad/ChangeLog16
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-0.10.19.ebuild49
2 files changed, 64 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-bad/ChangeLog b/media-libs/gst-plugins-bad/ChangeLog
index 13e12a7577e6..0f55ab8e662e 100644
--- a/media-libs/gst-plugins-bad/ChangeLog
+++ b/media-libs/gst-plugins-bad/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for media-libs/gst-plugins-bad
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.64 2010/07/12 22:47:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.65 2010/07/30 10:11:28 leio Exp $
+
+*gst-plugins-bad-0.10.19 (30 Jul 2010)
+
+ 30 Jul 2010; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-bad-0.10.19.ebuild:
+ Version bump with the following most noteworthy upstream changes:
+ New invtelecine plugin - detects and reconstructs progressive content
+ from telecine video. New segmentclip plugin - add audio/video buffer
+ segment clip elements.
+ Capssetter element has moved to gst-plugins-good-0.10.23+.
+ Bitrate calculation and estimation for audioparsers and mpegvideoparse.
+ Support for muxing VP8 video codec and XMP tags into quicktime video with
+ qtmux. Various new API and properties for camerabin. Many other bug fixes
+ and improvements.
12 Jul 2010; Jeroen Roovers <jer@gentoo.org>
gst-plugins-bad-0.10.18.ebuild:
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.19.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.19.ebuild
new file mode 100644
index 000000000000..f7ab09bc82d2
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.19.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.19.ebuild,v 1.1 2010/07/30 10:11:28 leio Exp $
+
+inherit gst-plugins-bad gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.29
+ >=media-libs/gstreamer-0.10.29
+ >=dev-libs/glib-2.16
+ !<media-plugins/gst-plugins-farsight-0.12.11"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# Avoid --enable-bad passing by the eclass blindly
+GST_PLUGINS_BUILD=""
+
+src_compile() {
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # (Bug #22249)
+
+ gst-plugins-bad_src_configure
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}