summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2008-02-21 10:42:22 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2008-02-21 10:42:22 +0000
commit9ed33cc069c97531c728dc93a5de2eb366a4aba1 (patch)
tree14db66c984a1c903a8424f3f9ca055ce1af33e33 /media-libs/gst-plugins-bad
parentalpha/ia64/sparc stable wrt #210649 (diff)
downloadgentoo-2-9ed33cc069c97531c728dc93a5de2eb366a4aba1.tar.gz
gentoo-2-9ed33cc069c97531c728dc93a5de2eb366a4aba1.tar.bz2
gentoo-2-9ed33cc069c97531c728dc93a5de2eb366a4aba1.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-libs/gst-plugins-bad')
-rw-r--r--media-libs/gst-plugins-bad/ChangeLog12
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-0.10.6.ebuild52
2 files changed, 61 insertions, 3 deletions
diff --git a/media-libs/gst-plugins-bad/ChangeLog b/media-libs/gst-plugins-bad/ChangeLog
index 283c85c6fde2..ce46fc2f302a 100644
--- a/media-libs/gst-plugins-bad/ChangeLog
+++ b/media-libs/gst-plugins-bad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-bad
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.12 2007/12/22 14:14:58 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.13 2008/02/21 10:42:22 zaheerm Exp $
+
+*gst-plugins-bad-0.10.6 (21 Feb 2008)
+
+ 21 Feb 2008; Zaheer Abbas Merali <zaheerm@gentoo.org>
+ +gst-plugins-bad-0.10.6.ebuild:
+ version bump
22 Dec 2007; Tobias Scherbaum <dertobi123@gentoo.org>
gst-plugins-bad-0.10.5.ebuild:
@@ -20,7 +26,7 @@
+gst-plugins-bad-0.10.5.ebuild:
Version bump.
- 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
+ 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
*gst-plugins-bad-0.10.4 (25 Jan 2007)
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.6.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.6.ebuild
new file mode 100644
index 000000000000..92b8446e5f97
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.6.ebuild,v 1.1 2008/02/21 10:42:22 zaheerm Exp $
+
+inherit gst-plugins-bad gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Unmaintained plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.17
+ >=media-libs/gstreamer-0.10.17"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ elibtoolize
+
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # (Bug #22249)
+
+ if use alpha || use amd64 || use ia64 || use hppa ; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins-bad_src_configure
+
+ emake || die
+}
+
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}