summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-26 11:20:45 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-26 11:20:45 +0000
commit0fefdd6298c3b8248f89b6b168d048a81f75f4da (patch)
treea80bf99aa40ebd025c78713bbae1c04328dc90a2 /media-libs/grilo
parentUpdate gnome 3.8 mask (diff)
downloadgentoo-2-0fefdd6298c3b8248f89b6b168d048a81f75f4da.tar.gz
gentoo-2-0fefdd6298c3b8248f89b6b168d048a81f75f4da.tar.bz2
gentoo-2-0fefdd6298c3b8248f89b6b168d048a81f75f4da.zip
Version bump, remove old
(Portage version: 2.1.12.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-libs/grilo')
-rw-r--r--media-libs/grilo/ChangeLog9
-rw-r--r--media-libs/grilo/files/grilo-0.2.6-testui-crash.patch57
-rw-r--r--media-libs/grilo/grilo-0.2.6.ebuild (renamed from media-libs/grilo/grilo-0.2.3.ebuild)68
3 files changed, 96 insertions, 38 deletions
diff --git a/media-libs/grilo/ChangeLog b/media-libs/grilo/ChangeLog
index 2e150b42a942..9b6e60fc33a6 100644
--- a/media-libs/grilo/ChangeLog
+++ b/media-libs/grilo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/grilo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/ChangeLog,v 1.25 2013/05/12 07:31:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/ChangeLog,v 1.26 2013/05/26 11:20:45 pacho Exp $
+
+*grilo-0.2.6 (26 May 2013)
+
+ 26 May 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/grilo-0.2.6-testui-crash.patch, +grilo-0.2.6.ebuild,
+ -grilo-0.2.3.ebuild:
+ Version bump, remove old
12 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Add doctype to metadata.xml
diff --git a/media-libs/grilo/files/grilo-0.2.6-testui-crash.patch b/media-libs/grilo/files/grilo-0.2.6-testui-crash.patch
new file mode 100644
index 000000000000..9ab58f37490a
--- /dev/null
+++ b/media-libs/grilo/files/grilo-0.2.6-testui-crash.patch
@@ -0,0 +1,57 @@
+From f581f2a456e6dbec76742b8e862feecee58e36b0 Mon Sep 17 00:00:00 2001
+From: Juan A. Suarez Romero <jasuarez@igalia.com>
+Date: Tue, 21 May 2013 14:01:10 +0000
+Subject: test-ui: Check if there is a reply from OAuth
+
+https://bugzilla.gnome.org/show_bug.cgi?id=700478
+---
+diff --git a/tools/grilo-test-ui/flickr-oauth.c b/tools/grilo-test-ui/flickr-oauth.c
+index 90679d2..8e847c5 100644
+--- a/tools/grilo-test-ui/flickr-oauth.c
++++ b/tools/grilo-test-ui/flickr-oauth.c
+@@ -74,6 +74,7 @@ flickroauth_get_request_token (const gchar *consumer_key,
+ gchar *params[7];
+ gchar *params_string; /* one string later created from params[] */
+ gchar *http_reply;
++ gchar *request_token = NULL;
+
+ timestamp = get_timestamp ();
+ nonce = oauth_gen_nonce ();
+@@ -107,7 +108,12 @@ flickroauth_get_request_token (const gchar *consumer_key,
+ http_reply = oauth_http_get2 (url, NULL, NULL);
+ g_free (url);
+
+- return parse_request_token (http_reply, secret);
++ if (http_reply) {
++ request_token = parse_request_token (http_reply, secret);
++ g_free (http_reply);
++ }
++
++ return request_token;
+ }
+
+ gchar *
+@@ -125,6 +131,7 @@ flickroauth_get_access_token (const gchar *consumer_key,
+ gchar *params[8];
+ gchar *params_string; /* one string later created from params[] */
+ gchar *http_reply;
++ gchar *access_token = NULL;
+
+ timestamp = get_timestamp ();
+ nonce = oauth_gen_nonce ();
+@@ -159,7 +166,12 @@ flickroauth_get_access_token (const gchar *consumer_key,
+ http_reply = oauth_http_get2 (url, NULL, NULL);
+ g_free (url);
+
+- return parse_access_token (http_reply, secret);
++ if (http_reply) {
++ access_token = parse_access_token (http_reply, secret);
++ g_free (http_reply);
++ }
++
++ return access_token;
+ }
+
+ gchar *
+--
+cgit v0.9.1
diff --git a/media-libs/grilo/grilo-0.2.3.ebuild b/media-libs/grilo/grilo-0.2.6.ebuild
index 826847f465e1..3c682d88f573 100644
--- a/media-libs/grilo/grilo-0.2.3.ebuild
+++ b/media-libs/grilo/grilo-0.2.6.ebuild
@@ -1,77 +1,71 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/grilo-0.2.3.ebuild,v 1.2 2012/12/10 02:40:29 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/grilo-0.2.6.ebuild,v 1.1 2013/05/26 11:20:45 pacho Exp $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="test? 2"
+PYTHON_COMPAT=( python2_{6,7} )
VALA_MIN_API_VERSION="0.12"
-VALA_MAX_API_VERSION="0.18" # explicitly specified in configure
+VALA_MAX_API_VERSION="0.20" # explicitly specified in configure
VALA_USE_DEPEND="vapigen"
-inherit gnome2 vala python
+inherit eutils gnome2 vala python-single-r1
DESCRIPTION="A framework for easy media discovery and browsing"
HOMEPAGE="https://live.gnome.org/Grilo"
LICENSE="LGPL-2.1+"
-SLOT="0.2"
-KEYWORDS="~amd64 ~x86"
+SLOT="0.2/1" # subslot is libgrilo-0.2 soname suffix
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="gtk examples +introspection +network test vala"
REQUIRED_USE="test? ( introspection )"
-RDEPEND=">=dev-libs/glib-2.29.10:2
+RDEPEND="
+ >=dev-libs/glib-2.29.10:2
dev-libs/libxml2:2
gtk? ( >=x11-libs/gtk+-3:3 )
introspection? ( >=dev-libs/gobject-introspection-0.9 )
- network? ( >=net-libs/libsoup-2.33.4:2.4 )"
+ network? ( >=net-libs/libsoup-2.41.3:2.4 )
+"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.10
virtual/pkgconfig
vala? ( $(vala_depend) )
test? (
- dev-python/pygobject:2
- dev-python/pygobject:3
- media-plugins/grilo-plugins:0.2 )"
+ ${PYTHON_DEPS}
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-plugins/grilo-plugins:0.2 )
+"
# eautoreconf requires gnome-common
-# Tests fail horribly, but return 0
-RESTRICT="test"
-
pkg_setup() {
- if use test; then
- python_pkg_setup
- python_set_active_version 2
- fi
+ use test && python-single-r1_pkg_setup
}
src_prepare() {
- DOCS="AUTHORS NEWS README TODO"
- # --enable-debug only changes CFLAGS, useless for us
- G2CONF="${G2CONF}
- --disable-static
- --disable-debug
- $(use_enable gtk test-ui)
- $(use_enable introspection)
- $(use_enable network grl-net)
- $(use_enable test tests)
- $(use_enable vala)"
-
# Don't build examples
sed -e '/SUBDIRS/s/examples//' \
-i Makefile.am -i Makefile.in || die
- # Add missing file from tarball
- cp "${FILESDIR}"/${PN}-0.1.16-constants.py \
- tests/python/constants.py || die
+ # Check if there is a reply from OAuth, upstream bug #700478
+ epatch "${FILESDIR}/${P}-testui-crash.patch"
use vala && vala_src_prepare
gnome2_src_prepare
}
-src_test() {
- emake check PYTHON=$(PYTHON -2)
+src_configure() {
+ # --enable-debug only changes CFLAGS, useless for us
+ gnome2_src_configure \
+ --disable-static \
+ --disable-debug \
+ $(use_enable gtk test-ui) \
+ $(use_enable introspection) \
+ $(use_enable network grl-net) \
+ $(use_enable test tests) \
+ $(use_enable vala)
}
src_install() {
@@ -82,7 +76,7 @@ src_install() {
# Prevent file collision with other slot
if use vala; then
mv "${ED}usr/bin/grilo-simple-playlist" \
- "${ED}usr/bin/grilo-simple-playlist-${SLOT}" || die
+ "${ED}usr/bin/grilo-simple-playlist-${SLOT%/*}" || die
fi
if use examples; then