summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-03 15:45:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-03 15:45:55 +0000
commit4a1c67c5eeef54fb72a1e711651ea6a21d1276c0 (patch)
treef8004f2b44e463138eebd951a06551c560dd12e6 /media-libs/gmtk
parentEmpty py-compile script instead of symlinking it wrt #397497 by "arnk" (diff)
downloadgentoo-2-4a1c67c5eeef54fb72a1e711651ea6a21d1276c0.tar.gz
gentoo-2-4a1c67c5eeef54fb72a1e711651ea6a21d1276c0.tar.bz2
gentoo-2-4a1c67c5eeef54fb72a1e711651ea6a21d1276c0.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gmtk')
-rw-r--r--media-libs/gmtk/ChangeLog9
-rw-r--r--media-libs/gmtk/gmtk-1.0.5.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/media-libs/gmtk/ChangeLog b/media-libs/gmtk/ChangeLog
index df73c561969c..bf671ed0dc66 100644
--- a/media-libs/gmtk/ChangeLog
+++ b/media-libs/gmtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gmtk
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gmtk/ChangeLog,v 1.1 2011/11/18 14:33:39 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gmtk/ChangeLog,v 1.2 2012/01/03 15:45:55 ssuominen Exp $
+
+*gmtk-1.0.5 (03 Jan 2012)
+
+ 03 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +gmtk-1.0.5.ebuild:
+ Version bump.
*gmtk-1.0.5_beta1 (18 Nov 2011)
diff --git a/media-libs/gmtk/gmtk-1.0.5.ebuild b/media-libs/gmtk/gmtk-1.0.5.ebuild
new file mode 100644
index 000000000000..bd608d2ad45a
--- /dev/null
+++ b/media-libs/gmtk/gmtk-1.0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gmtk/gmtk-1.0.5.ebuild,v 1.1 2012/01/03 15:45:55 ssuominen Exp $
+
+EAPI=4
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="GTK+ widget and function libraries for gnome-mplayer"
+HOMEPAGE="http://code.google.com/p/gmtk/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa +dconf pulseaudio"
+
+COMMON_DEPEND=">=dev-libs/glib-2.26
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+RDEPEND="${COMMON_DEPEND}
+ dconf? ( gnome-base/dconf )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ # http://code.google.com/p/gmtk/issues/detail?id=5
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags gtk+-3.0)"
+
+ econf \
+ --disable-static \
+ --enable-gtk3 \
+ $(use_enable dconf gsettings) \
+ --disable-gconf \
+ $(use_enable !dconf keystore) \
+ --with-gio \
+ $(use_with alsa) \
+ $(use_with pulseaudio)
+}
+
+src_install() {
+ default
+
+ rm -rf \
+ "${ED}"usr/share/doc/${PN} \
+ "${ED}"usr/lib*/*.la
+}