summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-08-29 19:52:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-08-29 19:52:26 +0000
commit531876cbbeeafe0d999b478f2d6b1b54fdef98cb (patch)
tree98ac2a32f2493f97e5c777fc1593b306998395c3 /media-libs/glfw
parentfix automagic on libXv, bug #520086 (diff)
downloadgentoo-2-531876cbbeeafe0d999b478f2d6b1b54fdef98cb.tar.gz
gentoo-2-531876cbbeeafe0d999b478f2d6b1b54fdef98cb.tar.bz2
gentoo-2-531876cbbeeafe0d999b478f2d6b1b54fdef98cb.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs/glfw')
-rw-r--r--media-libs/glfw/ChangeLog7
-rw-r--r--media-libs/glfw/glfw-3.0.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/media-libs/glfw/ChangeLog b/media-libs/glfw/ChangeLog
index 3c834bd5fb56..8eeb3a80b263 100644
--- a/media-libs/glfw/ChangeLog
+++ b/media-libs/glfw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/glfw
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glfw/ChangeLog,v 1.19 2014/08/29 19:17:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glfw/ChangeLog,v 1.20 2014/08/29 19:52:26 mr_bones_ Exp $
+
+*glfw-3.0.4 (29 Aug 2014)
+
+ 29 Aug 2014; Michael Sterrett <mr_bones_@gentoo.org> +glfw-3.0.4.ebuild:
+ version bump
29 Aug 2014; Michael Sterrett <mr_bones_@gentoo.org> glfw-2.6.ebuild,
glfw-2.7.7.ebuild, glfw-3.0.3.ebuild:
diff --git a/media-libs/glfw/glfw-3.0.4.ebuild b/media-libs/glfw/glfw-3.0.4.ebuild
new file mode 100644
index 000000000000..a74f2719fdaf
--- /dev/null
+++ b/media-libs/glfw/glfw-3.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glfw/glfw-3.0.4.ebuild,v 1.1 2014/08/29 19:52:26 mr_bones_ Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="http://www.glfw.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="egl examples"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ virtual/glu"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use egl GLFW_USE_EGL)
+ $(cmake-utils_use examples GLFW_BUILD_EXAMPLES)
+ -DBUILD_SHARED_LIBS=1
+ "
+ cmake-utils_src_configure
+}