summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAJ Lewis <aj@gentoo.org>2001-05-07 20:08:03 +0000
committerAJ Lewis <aj@gentoo.org>2001-05-07 20:08:03 +0000
commit1b8d5d4d941cc420643cc4b7dc140b36fb830410 (patch)
treec93fbf4538c6c5dd4cbd1fe5cd1508f1ffd75d82 /media-libs/giflib/giflib-4.1.0-r3.ebuild
parentAdded gdm support (diff)
downloadgentoo-2-1b8d5d4d941cc420643cc4b7dc140b36fb830410.tar.gz
gentoo-2-1b8d5d4d941cc420643cc4b7dc140b36fb830410.tar.bz2
gentoo-2-1b8d5d4d941cc420643cc4b7dc140b36fb830410.zip
o Updated giflib and libungif to check for 'ungif' and 'gif' USE variables
respectively o Added MagicPoint package - a cool presentation tool for X
Diffstat (limited to 'media-libs/giflib/giflib-4.1.0-r3.ebuild')
-rw-r--r--media-libs/giflib/giflib-4.1.0-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/giflib/giflib-4.1.0-r3.ebuild b/media-libs/giflib/giflib-4.1.0-r3.ebuild
new file mode 100644
index 000000000000..e8b61af262a2
--- /dev/null
+++ b/media-libs/giflib/giflib-4.1.0-r3.ebuild
@@ -0,0 +1,52 @@
+## Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# Updated by AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-4.1.0-r3.ebuild,v 1.1 2001/05/07 20:08:03 aj Exp $
+
+P=giflib-4.1.0
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="giflib"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/libs/giflib/${A}
+ ftp://prtr-13.ucsc.edu/pub/libungif/${A}"
+
+HOMEPAGE="http://prtr-13.ucsc.edu/~badger/software/libungif/index.shtml"
+
+DEPEND="virtual/glibc
+ X? ( virtual/x11 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use X`" ]
+ then
+ myconf="--with-x"
+ else
+ myconf="--without-x"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr ${myconf}
+
+ try make
+
+}
+
+src_install() {
+
+ try make prefix=${D}/usr install
+ if [ "`use ungif`" ]
+ then
+ rm -rf ${D}/usr/bin
+ fi
+
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS ONEWS
+ dodoc PATENT_PROBLEMS README TODO
+ dodoc doc/*.txt
+ docinto html
+ dodoc doc/*.html doc/*.png
+
+}
+
+
+