summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-01-15 14:01:07 +0000
committerHanno Böck <hanno@gentoo.org>2009-01-15 14:01:07 +0000
commit7380e769c9e651e1dcb4879e4b2b992856c9e185 (patch)
treef16373325dd6ca9d1f23d391953d168084b8ad93 /media-libs/gegl
parentVersion bump (diff)
downloadgentoo-2-7380e769c9e651e1dcb4879e4b2b992856c9e185.tar.gz
gentoo-2-7380e769c9e651e1dcb4879e4b2b992856c9e185.tar.bz2
gentoo-2-7380e769c9e651e1dcb4879e4b2b992856c9e185.zip
gegl: add missing include of locale.h
(Portage version: 2.2_rc22/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/ChangeLog6
-rw-r--r--media-libs/gegl/files/gegl-0.0.22-locale_h.diff10
-rw-r--r--media-libs/gegl/gegl-0.0.22.ebuild8
3 files changed, 22 insertions, 2 deletions
diff --git a/media-libs/gegl/ChangeLog b/media-libs/gegl/ChangeLog
index 8433df2dff99..56e5a291c5e0 100644
--- a/media-libs/gegl/ChangeLog
+++ b/media-libs/gegl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/gegl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/ChangeLog,v 1.18 2009/01/10 23:08:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/ChangeLog,v 1.19 2009/01/15 14:01:07 hanno Exp $
+
+ 15 Jan 2009; Hanno Boeck <hanno@gentoo.org>
+ +files/gegl-0.0.22-locale_h.diff, gegl-0.0.22.ebuild:
+ Add missing include, fixes #254619.
10 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> gegl-0.0.22.ebuild:
inherit goes near the top
diff --git a/media-libs/gegl/files/gegl-0.0.22-locale_h.diff b/media-libs/gegl/files/gegl-0.0.22-locale_h.diff
new file mode 100644
index 000000000000..a4a9707fc24b
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.0.22-locale_h.diff
@@ -0,0 +1,10 @@
+--- gegl-0.0.22/gegl/gegl-init.c 2008-12-31 02:38:59.000000000 +0100
++++ gegl-0.0.22-1/gegl/gegl-init.c 2009-01-14 22:21:41.000000000 +0100
+@@ -26,6 +26,7 @@
+ #include <glib/gi18n-lib.h>
+
+ #include <stdlib.h>
++#include <locale.h>
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
diff --git a/media-libs/gegl/gegl-0.0.22.ebuild b/media-libs/gegl/gegl-0.0.22.ebuild
index 1f16ba83ee1d..1664bb9ed942 100644
--- a/media-libs/gegl/gegl-0.0.22.ebuild
+++ b/media-libs/gegl/gegl-0.0.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/gegl-0.0.22.ebuild,v 1.4 2009/01/10 23:08:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/gegl-0.0.22.ebuild,v 1.5 2009/01/15 14:01:07 hanno Exp $
inherit eutils
@@ -40,6 +40,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-locale_h.diff"
+}
+
src_compile() {
econf --with-gtk --with-pango --with-gdk-pixbuf \
$(use_enable debug) \