summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-06-17 12:40:31 +0000
committerThomas Sachau <tommy@gentoo.org>2012-06-17 12:40:31 +0000
commit5af313ed12a8a1ba62f6ee487544d0762b303cca (patch)
tree71933c4018e9a036d4cb377afd16f3e2184f6655 /media-libs/evas
parentwake up before you commit (diff)
downloadgentoo-2-5af313ed12a8a1ba62f6ee487544d0762b303cca.tar.gz
gentoo-2-5af313ed12a8a1ba62f6ee487544d0762b303cca.tar.bz2
gentoo-2-5af313ed12a8a1ba62f6ee487544d0762b303cca.zip
Version bump
(Portage version: 2.2.0_alpha110-r1/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/evas')
-rw-r--r--media-libs/evas/ChangeLog7
-rw-r--r--media-libs/evas/evas-1.2.1.ebuild138
2 files changed, 144 insertions, 1 deletions
diff --git a/media-libs/evas/ChangeLog b/media-libs/evas/ChangeLog
index 88eecb682639..c43399505fbb 100644
--- a/media-libs/evas/ChangeLog
+++ b/media-libs/evas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/evas
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/evas/ChangeLog,v 1.9 2012/02/08 20:33:23 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/evas/ChangeLog,v 1.10 2012/06/17 12:40:31 tommy Exp $
+
+*evas-1.2.1 (17 Jun 2012)
+
+ 17 Jun 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> +evas-1.2.1.ebuild:
+ Version bump
08 Feb 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
-files/evas-1.0.0-libpng-1.5.patch:
diff --git a/media-libs/evas/evas-1.2.1.ebuild b/media-libs/evas/evas-1.2.1.ebuild
new file mode 100644
index 000000000000..c7556c323518
--- /dev/null
+++ b/media-libs/evas/evas-1.2.1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/evas/evas-1.2.1.ebuild,v 1.1 2012/06/17 12:40:31 tommy Exp $
+
+EAPI=2
+
+inherit enlightenment
+
+DESCRIPTION="hardware-accelerated retained canvas API"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Evas"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="altivec bidi +bmp directfb +eet fbcon +fontconfig gles gif +ico +jpeg mmx opengl +png +ppm +psd sdl sse sse3 svg static-libs tga +threads tiff X xcb xpm"
+
+RDEPEND=">=dev-libs/eina-1.2.0
+ >=media-libs/freetype-2.3.9
+ fontconfig? ( media-libs/fontconfig )
+ gles? ( media-libs/mesa[gallium,gles] )
+ gif? ( media-libs/giflib )
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )
+ bidi? ( >=dev-libs/fribidi-0.19.1 )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ sdl? ( media-libs/libsdl )
+ tiff? ( media-libs/tiff )
+ xpm? ( x11-libs/libXpm )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ opengl? ( virtual/opengl )
+ )
+ !X? (
+ xcb? (
+ x11-libs/xcb-util
+ ) )
+ eet? ( >=dev-libs/eet-1.2.0 )
+ svg? (
+ >=gnome-base/librsvg-2.14.0
+ x11-libs/cairo
+ x11-libs/libsvg-cairo
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ if use X ; then
+ if use xcb ; then
+ ewarn "You have enabled both 'X' and 'xcb', so we will use"
+ ewarn "X as it's considered the most stable for evas"
+ fi
+ MY_ECONF="
+ --disable-software-xcb
+ $(use_enable opengl gl-xlib)
+ "
+ elif use xcb ; then
+ MY_ECONF="
+ --disable-gl-xlib
+ --enable-software-xcb
+ $(use_enable opengl gl-xcb)
+ "
+ else
+ MY_ECONF="
+ --disable-gl-xlib
+ --disable-software-xcb
+ --disable-gl-xcb
+ "
+ fi
+
+ MY_ECONF+="
+ --disable-metric-cache
+ --disable-word-cache
+ $(use_enable altivec cpu-altivec)
+ $(use_enable bidi fribidi)
+ $(use_enable bmp image-loader-bmp)
+ $(use_enable bmp image-loader-wbmp)
+ $(use_enable directfb)
+ $(use_enable doc)
+ $(use_enable eet font-loader-eet)
+ $(use_enable eet image-loader-eet)
+ $(use_enable fbcon fb)
+ $(use_enable fontconfig)
+ $(use_enable gles gl-flavor-gles)
+ $(use_enable gles gles-variety-sgx)
+ $(use_enable gif image-loader-gif)
+ $(use_enable ico image-loader-ico)
+ $(use_enable jpeg image-loader-jpeg)
+ $(use_enable mmx cpu-mmx)
+ $(use_enable png image-loader-png)
+ $(use_enable ppm image-loader-pmaps)
+ $(use_enable psd image-loader-psd)
+ $(use_enable sdl software-sdl)
+ $(use_enable sse cpu-sse)
+ $(use_enable sse3 cpu-sse3)
+ $(use_enable svg image-loader-svg)
+ $(use_enable tga image-loader-tga)
+ $(use_enable tiff image-loader-tiff)
+ $(use_enable threads pthreads)
+ $(use_enable threads async-events)
+ $(use_enable threads async-preload)
+ $(use_enable threads async-render)
+ $(use_enable X software-xlib)
+ $(use_enable xpm image-loader-xpm)
+ --enable-evas-magic-debug \
+ --enable-static-software-generic \
+ --enable-buffer \
+ --enable-cpu-c \
+ --enable-scale-sample \
+ --enable-scale-smooth \
+ --enable-convert-8-rgb-332 \
+ --enable-convert-8-rgb-666 \
+ --enable-convert-8-rgb-232 \
+ --enable-convert-8-rgb-222 \
+ --enable-convert-8-rgb-221 \
+ --enable-convert-8-rgb-121 \
+ --enable-convert-8-rgb-111 \
+ --enable-convert-16-rgb-565 \
+ --enable-convert-16-rgb-555 \
+ --enable-convert-16-rgb-444 \
+ --enable-convert-16-rgb-rot-0 \
+ --enable-convert-16-rgb-rot-270 \
+ --enable-convert-16-rgb-rot-90 \
+ --enable-convert-24-rgb-888 \
+ --enable-convert-24-bgr-888 \
+ --enable-convert-32-rgb-8888 \
+ --enable-convert-32-rgbx-8888 \
+ --enable-convert-32-bgr-8888 \
+ --enable-convert-32-bgrx-8888 \
+ --enable-convert-32-rgb-rot-0 \
+ --enable-convert-32-rgb-rot-270 \
+ --enable-convert-32-rgb-rot-90 \
+ --enable-image-loader-generic \
+ --disable-image-loader-edb \
+ --disable-static-software-16 \
+ --disable-software-16-x11"
+
+ enlightenment_src_configure
+}