summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-05-29 16:14:58 +0000
committerThomas Sachau <tommy@gentoo.org>2011-05-29 16:14:58 +0000
commitd2939979217748f5f0959f8c302b105062097888 (patch)
tree395b8d4dedb74ce9d2c66c7337717160d6838fe9 /media-libs/edje
parentUse.mask prelude (diff)
downloadgentoo-2-d2939979217748f5f0959f8c302b105062097888.tar.gz
gentoo-2-d2939979217748f5f0959f8c302b105062097888.tar.bz2
gentoo-2-d2939979217748f5f0959f8c302b105062097888.zip
Version bump
(Portage version: 2.2.0_alpha37-r1/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/edje')
-rw-r--r--media-libs/edje/ChangeLog7
-rw-r--r--media-libs/edje/edje-1.0.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/media-libs/edje/ChangeLog b/media-libs/edje/ChangeLog
index db78885ad1e4..5176ab88fffc 100644
--- a/media-libs/edje/ChangeLog
+++ b/media-libs/edje/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/edje
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/edje/ChangeLog,v 1.11 2011/03/13 10:19:32 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/edje/ChangeLog,v 1.12 2011/05/29 16:14:58 tommy Exp $
+
+*edje-1.0.1 (29 May 2011)
+
+ 29 May 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> +edje-1.0.1.ebuild:
+ Version bump
13 Mar 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> edje-1.0.0.ebuild:
Fix dependency version for eet
diff --git a/media-libs/edje/edje-1.0.1.ebuild b/media-libs/edje/edje-1.0.1.ebuild
new file mode 100644
index 000000000000..45587e109600
--- /dev/null
+++ b/media-libs/edje/edje-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/edje/edje-1.0.1.ebuild,v 1.1 2011/05/29 16:14:58 tommy Exp $
+
+inherit enlightenment
+
+DESCRIPTION="graphical layout and animation library"
+HOMEPAGE="http://www.enlightenment.org/pages/edje.html"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug cache static-libs vim-syntax"
+
+DEPEND="dev-lang/lua
+ >=dev-libs/eet-1.4.0_beta
+ >=dev-libs/eina-1.0.0_beta
+ >=dev-libs/embryo-1.0.0_beta
+ >=media-libs/evas-1.0.0_beta
+ >=dev-libs/ecore-1.0.0_beta"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ export MY_ECONF="
+ $(use_enable cache edje-program-cache)
+ $(use_enable cache edje-calc-cache)
+ $(use_enable !debug amalgamation)
+ $(use_with vim-syntax vim /usr/share/vim)
+ "
+ enlightenment_src_compile
+}
+
+src_install() {
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins data/edc.vim || die
+ fi
+ dodoc utils/{gimp-edje-export.py,inkscape2edc} || die
+ enlightenment_src_install
+}