summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-09-01 11:10:33 +0000
committerPacho Ramos <pacho@gentoo.org>2013-09-01 11:10:33 +0000
commit6be31f0fd4279293817034607b6493ac2fd978be (patch)
treef3887acf44f22605ebb9448cd2b462b604c2460f /media-libs/cogl
parentVersion bump. Clean up old revision. (diff)
downloadgentoo-2-6be31f0fd4279293817034607b6493ac2fd978be.tar.gz
gentoo-2-6be31f0fd4279293817034607b6493ac2fd978be.tar.bz2
gentoo-2-6be31f0fd4279293817034607b6493ac2fd978be.zip
Bump including all commits from 1.14 branch (fixing #481348 by Kamil Kamiński also)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-libs/cogl')
-rw-r--r--media-libs/cogl/ChangeLog8
-rw-r--r--media-libs/cogl/cogl-1.14.1_pre20130901.ebuild96
2 files changed, 103 insertions, 1 deletions
diff --git a/media-libs/cogl/ChangeLog b/media-libs/cogl/ChangeLog
index 0b3d3f6f6687..912b134f3de5 100644
--- a/media-libs/cogl/ChangeLog
+++ b/media-libs/cogl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/cogl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.35 2013/07/27 23:57:28 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.36 2013/09/01 11:10:33 pacho Exp $
+
+*cogl-1.14.1_pre20130901 (01 Sep 2013)
+
+ 01 Sep 2013; Pacho Ramos <pacho@gentoo.org> +cogl-1.14.1_pre20130901.ebuild:
+ Bump including all commits from 1.14 branch (fixing #481348 by Kamil Kamiński
+ also)
27 Jul 2013; Gilles Dartiguelongue <eva@gentoo.org> cogl-1.14.0.ebuild:
Add missing dependency, per configure.
diff --git a/media-libs/cogl/cogl-1.14.1_pre20130901.ebuild b/media-libs/cogl/cogl-1.14.1_pre20130901.ebuild
new file mode 100644
index 000000000000..11b127156a89
--- /dev/null
+++ b/media-libs/cogl/cogl-1.14.1_pre20130901.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.14.1_pre20130901.ebuild,v 1.1 2013/09/01 11:10:33 pacho Exp $
+
+EAPI="5"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+inherit eutils clutter gnome2 multilib virtualx
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.clutter-project.org/"
+
+SRC_URI="${SRC_URI} http://dev.gentoo.org/~pacho/gnome/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0/12" # subslot = .so version
+IUSE="doc examples +introspection +opengl gles2 +pango profile"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# XXX: need uprof for optional profiling support
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ x11-libs/cairo:=
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm:=
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXrandr-1.2
+ virtual/opengl
+ gles2? ( media-libs/mesa[gles2] )
+
+ introspection? ( >=dev-libs/gobject-introspection-1.34.2 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )
+"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ test? ( app-admin/eselect-opengl
+ media-libs/mesa[classic] )
+"
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
+
+S="${WORKDIR}/${PN}-1.14.1"
+
+src_configure() {
+ # XXX: think about kms-egl, quartz, sdl, wayland
+ # Prefer gl over gles2 if both are selected
+ gnome2_src_configure \
+ --disable-examples-install \
+ --disable-maintainer-flags \
+ --enable-cairo \
+ --enable-deprecated \
+ --enable-gdk-pixbuf \
+ --enable-glib \
+ $(use_enable doc gtk-doc) \
+ $(use_enable opengl glx) \
+ $(use_enable opengl gl) \
+ $(use_enable gles2) \
+ $(use_enable gles2 cogl-gles2) \
+ $(use_enable gles2 xlib-egl-platform) \
+ $(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
+ $(use_enable introspection) \
+ $(use_enable pango cogl-pango) \
+ $(use_enable profile)
+}
+
+src_test() {
+ # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
+ # NOTE: recheck if this is needed after every mesa bump
+ if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
+ ewarn "Skipping tests because a binary OpenGL library is enabled. To"
+ ewarn "run tests for ${PN}, you need to enable the Mesa library:"
+ ewarn "# eselect opengl set xorg-x11"
+ return
+ fi
+ LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa" Xemake check
+}
+
+src_install() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/{*.c,*.jpg}"
+
+ clutter_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+}