summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-01-13 16:13:58 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-01-13 16:13:58 +0000
commit2dc9eb3e16d0837c839cbee901131034fc325307 (patch)
tree49a399bdf0a25c31b9a4360587e7e32e3e9f01ef /media-libs/cogl
parentStabilizing r9 (diff)
downloadgentoo-2-2dc9eb3e16d0837c839cbee901131034fc325307.tar.gz
gentoo-2-2dc9eb3e16d0837c839cbee901131034fc325307.tar.bz2
gentoo-2-2dc9eb3e16d0837c839cbee901131034fc325307.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs/cogl')
-rw-r--r--media-libs/cogl/ChangeLog8
-rw-r--r--media-libs/cogl/cogl-1.12.2.ebuild (renamed from media-libs/cogl/cogl-1.12.0.ebuild)63
2 files changed, 39 insertions, 32 deletions
diff --git a/media-libs/cogl/ChangeLog b/media-libs/cogl/ChangeLog
index 82a3c57c1317..4335f0a40de8 100644
--- a/media-libs/cogl/ChangeLog
+++ b/media-libs/cogl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/cogl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.20 2013/01/06 09:47:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.21 2013/01/13 16:13:58 eva Exp $
+
+*cogl-1.12.2 (13 Jan 2013)
+
+ 13 Jan 2013; Gilles Dartiguelongue <eva@gentoo.org> -cogl-1.12.0.ebuild,
+ +cogl-1.12.2.ebuild:
+ Version bump.
06 Jan 2013; Agostino Sarubbo <ago@gentoo.org> cogl-1.12.0-r1.ebuild:
Add ~sparc, wrt bug #449220
diff --git a/media-libs/cogl/cogl-1.12.0.ebuild b/media-libs/cogl/cogl-1.12.2.ebuild
index 04a4e6a676ff..1451f56111fd 100644
--- a/media-libs/cogl/cogl-1.12.0.ebuild
+++ b/media-libs/cogl/cogl-1.12.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.12.0.ebuild,v 1.1 2012/12/16 22:03:51 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.12.2.ebuild,v 1.1 2013/01/13 16:13:58 eva Exp $
EAPI="5"
CLUTTER_LA_PUNT="yes"
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.clutter-project.org/"
LICENSE="LGPL-2.1+ FDL-1.1+"
SLOT="1.0/11"
IUSE="doc examples +introspection +opengl gles2 +pango"
-KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
# XXX: need uprof for optional profiling support
COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
@@ -31,45 +31,39 @@ COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
gles2? ( media-libs/mesa[gles2] )
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )
+"
# before clutter-1.7, cogl was part of clutter
RDEPEND="${COMMON_DEPEND}
!<media-libs/clutter-1.7"
DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.13
sys-devel/gettext
virtual/pkgconfig
- doc? ( app-text/docbook-xml-dtd:4.1.2
- >=dev-util/gtk-doc-1.13 )
test? ( app-admin/eselect-opengl
- media-libs/mesa[classic] )"
+ media-libs/mesa[classic] )
+"
# Need classic mesa swrast for tests, llvmpipe causes a test failure
-src_prepare() {
- DOCS="NEWS README"
- EXAMPLES="examples/{*.c,*.jpg}"
+src_configure() {
# XXX: think about kms-egl, quartz, sdl, wayland
- G2CONF="${G2CONF}
- --disable-examples-install
- --disable-profile
- --disable-maintainer-flags
- --enable-cairo
- --enable-gdk-pixbuf
- $(use_enable opengl glx)
- $(use_enable opengl gl)
- $(use_enable gles2)
- $(use_enable gles2 cogl-gles2)
- $(use_enable gles2 xlib-egl-platform)
- "$(usex gles2 --with-default-driver=gles2 "")"
- --enable-glib
- --enable-deprecated
- $(use_enable introspection)
+ # Prefer gl over gles2 if both are selected
+ gnome2_src_configure \
+ --disable-examples-install \
+ --disable-profile \
+ --disable-maintainer-flags \
+ --enable-cairo \
+ --enable-deprecated \
+ --enable-gdk-pixbuf \
+ --enable-glib \
+ $(use_enable opengl glx) \
+ $(use_enable opengl gl) \
+ $(use_enable gles2) \
+ $(use_enable gles2 cogl-gles2) \
+ $(use_enable gles2 xlib-egl-platform) \
+ $(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
+ $(use_enable introspection) \
$(use_enable pango cogl-pango)
- $(use_enable doc gtk-doc)"
- # Really need --enable-gtk-doc for docs
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=684731
- epatch "${FILESDIR}/${PN}-1.12.0-fix-experimental-doc-build.patch"
- gnome2_src_prepare
}
src_test() {
@@ -85,8 +79,15 @@ src_test() {
}
src_install() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/{*.c,*.jpg}"
+
clutter_src_install
+ # Make sure gtk-doc is installed
+ cd "${S}"/doc || die
+ emake install DESTDIR="${D}" || die
+
# Remove silly examples-data directory
rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
}