summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2014-11-09 12:05:46 +0000
committerBen de Groot <yngwin@gentoo.org>2014-11-09 12:05:46 +0000
commitda4da29c3b1e8be7fc43623f50810f1b167f4b4d (patch)
tree44bf03d0ba99c3ae369d076ddecb89b0fe74d96f /media-libs/chromaprint
parentBump to EAPI=5 (bug #527914) (diff)
downloadgentoo-2-da4da29c3b1e8be7fc43623f50810f1b167f4b4d.tar.gz
gentoo-2-da4da29c3b1e8be7fc43623f50810f1b167f4b4d.tar.bz2
gentoo-2-da4da29c3b1e8be7fc43623f50810f1b167f4b4d.zip
Version bump. Thanks to dolphinling in bug #521816 for the updated ebuild.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x0F9C590B7FF324F6!)
Diffstat (limited to 'media-libs/chromaprint')
-rw-r--r--media-libs/chromaprint/ChangeLog7
-rw-r--r--media-libs/chromaprint/chromaprint-1.2.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/media-libs/chromaprint/ChangeLog b/media-libs/chromaprint/ChangeLog
index 747f54af4843..1929baa96cfe 100644
--- a/media-libs/chromaprint/ChangeLog
+++ b/media-libs/chromaprint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/chromaprint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.17 2014/03/04 20:17:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.18 2014/11/09 12:05:46 yngwin Exp $
+
+*chromaprint-1.2 (09 Nov 2014)
+
+ 09 Nov 2014; Ben de Groot <yngwin@gentoo.org> +chromaprint-1.2.ebuild:
+ Version bump. Thanks to dolphinling in bug #521816 for the updated ebuild.
04 Mar 2014; Agostino Sarubbo <ago@gentoo.org> chromaprint-1.1.ebuild:
Stable for x86, wrt bug #500882
diff --git a/media-libs/chromaprint/chromaprint-1.2.ebuild b/media-libs/chromaprint/chromaprint-1.2.ebuild
new file mode 100644
index 000000000000..b4c4b6d78c02
--- /dev/null
+++ b/media-libs/chromaprint/chromaprint-1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-1.2.ebuild,v 1.1 2014/11/09 12:05:46 yngwin Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A client-side library that implements a custom algorithm for extracting fingerprints"
+HOMEPAGE="http://acoustid.org/chromaprint"
+SRC_URI="https://bitbucket.org/acoustid/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd"
+IUSE="test tools"
+
+# note: use ffmpeg instead of fftw because it's recommended and required for tools
+RDEPEND=">=virtual/ffmpeg-0.10"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ dev-libs/boost
+ )"
+
+DOCS="NEWS.txt README.md"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1-gtest.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build tools EXAMPLES)
+ $(cmake-utils_use_build test TESTS)
+ -DWITH_AVFFT=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+}