summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2013-02-16 16:54:21 +0000
committerLuca Barbato <lu_zero@gentoo.org>2013-02-16 16:54:21 +0000
commit1439606da801d33593d100e9fd3a139f47d931c9 (patch)
tree42577a6e20f727474fa4071e5302d8e708b8037c /media-libs/chromaprint
parentinitial import wrt #365595 (diff)
downloadgentoo-2-1439606da801d33593d100e9fd3a139f47d931c9.tar.gz
gentoo-2-1439606da801d33593d100e9fd3a139f47d931c9.tar.bz2
gentoo-2-1439606da801d33593d100e9fd3a139f47d931c9.zip
Support libav9 api (fix bug 443250)
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 1191738E)
Diffstat (limited to 'media-libs/chromaprint')
-rw-r--r--media-libs/chromaprint/ChangeLog8
-rw-r--r--media-libs/chromaprint/chromaprint-0.7.ebuild8
-rw-r--r--media-libs/chromaprint/files/chromaprint-0.7-libav9.patch44
3 files changed, 55 insertions, 5 deletions
diff --git a/media-libs/chromaprint/ChangeLog b/media-libs/chromaprint/ChangeLog
index 345ef85b5533..837c7b33995d 100644
--- a/media-libs/chromaprint/ChangeLog
+++ b/media-libs/chromaprint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/chromaprint
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.6 2012/12/12 16:25:32 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.7 2013/02/16 16:54:21 lu_zero Exp $
+
+ 16 Feb 2013; Luca Barbato <lu_zero@gentoo.org> chromaprint-0.7.ebuild,
+ +files/chromaprint-0.7-libav9.patch:
+ Support libav9 api (fix bug 443250)
12 Dec 2012; Agostino Sarubbo <ago@gentoo.org> chromaprint-0.7.ebuild:
Add ~ppc, wrt bug #426340
diff --git a/media-libs/chromaprint/chromaprint-0.7.ebuild b/media-libs/chromaprint/chromaprint-0.7.ebuild
index 848e935e9913..182536592bfb 100644
--- a/media-libs/chromaprint/chromaprint-0.7.ebuild
+++ b/media-libs/chromaprint/chromaprint-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-0.7.ebuild,v 1.3 2012/12/12 16:25:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-0.7.ebuild,v 1.4 2013/02/16 16:54:21 lu_zero Exp $
EAPI=4
inherit cmake-utils
@@ -26,7 +26,9 @@ DEPEND="${RDEPEND}
DOCS="NEWS.txt README.txt"
-PATCHES=( "${FILESDIR}"/${P}-boost.patch "${FILESDIR}"/${P}-ffmpeg.patch )
+PATCHES=( "${FILESDIR}"/${P}-boost.patch
+ "${FILESDIR}"/${P}-ffmpeg.patch
+ "${FILESDIR}"/${P}-libav9.patch )
src_configure() {
local mycmakeargs=(
diff --git a/media-libs/chromaprint/files/chromaprint-0.7-libav9.patch b/media-libs/chromaprint/files/chromaprint-0.7-libav9.patch
new file mode 100644
index 000000000000..c52097056377
--- /dev/null
+++ b/media-libs/chromaprint/files/chromaprint-0.7-libav9.patch
@@ -0,0 +1,44 @@
+diff -burN chromaprint-0.7.orig//src/fft_lib_avfft.h chromaprint-0.7/src/fft_lib_avfft.h
+--- chromaprint-0.7.orig//src/fft_lib_avfft.h 2012-09-05 20:05:36.000000000 +0200
++++ chromaprint-0.7/src/fft_lib_avfft.h 2013-02-16 17:34:08.682624779 +0100
+@@ -25,6 +25,7 @@
+ extern "C" {
+ #include <libavcodec/avcodec.h>
+ #include <libavcodec/avfft.h>
++#include <libavutil/mem.h>
+ }
+ #include "combined_buffer.h"
+
+diff -burN chromaprint-0.7.orig/examples/fpcalc.c chromaprint-0.7/work/chromaprint-0.7/examples/fpcalc.c
+--- chromaprint-0.7.orig/examples/fpcalc.c 2012-09-05 20:05:36.000000000 +0200
++++ chromaprint-0.7/examples/fpcalc.c 2013-02-16 17:40:09.947611629 +0100
+@@ -42,7 +42,7 @@
+ goto done;
+ }
+
+- if (av_find_stream_info(format_ctx) < 0) {
++ if (avformat_find_stream_info(format_ctx, NULL) < 0) {
+ fprintf(stderr, "ERROR: couldn't find stream information in the file\n");
+ goto done;
+ }
+@@ -65,7 +65,7 @@
+ goto done;
+ }
+
+- if (avcodec_open(codec_ctx, codec) < 0) {
++ if (avcodec_open2(codec_ctx, codec, NULL) < 0) {
+ fprintf(stderr, "ERROR: couldn't open the codec\n");
+ goto done;
+ }
+diff -burN chromaprint-0.7.orig/src/ext/ffmpeg_decoder.h chromaprint-0.7/src/ext/ffmpeg_decoder.h
+--- chromaprint-0.7.orig/src/ext/ffmpeg_decoder.h 2013-02-16 17:49:06.799592088 +0100
++++ chromaprint-0.7/src/ext/ffmpeg_decoder.h 2013-02-16 17:49:54.037590369 +0100
+@@ -124,7 +124,7 @@
+ return false;
+ }
+
+- if (avcodec_open(m_codec_ctx, codec) < 0) {
++ if (avcodec_open2(m_codec_ctx, codec, NULL) < 0) {
+ m_error = "Couldn't open the codec.";
+ return false;
+ }