summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-23 15:58:24 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-23 15:58:24 +0000
commitb194fdca3581d47749d7f5defbb9e0076f59ba9c (patch)
tree7e62cdcb4c79572c8550df7096d1f2e6d7a4c36a /media-libs/babl
parentDon't unmask introspection on stable babl (diff)
downloadgentoo-2-b194fdca3581d47749d7f5defbb9e0076f59ba9c.tar.gz
gentoo-2-b194fdca3581d47749d7f5defbb9e0076f59ba9c.tar.bz2
gentoo-2-b194fdca3581d47749d7f5defbb9e0076f59ba9c.zip
Bump babl to ~arch for introspection
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/babl')
-rw-r--r--media-libs/babl/ChangeLog7
-rw-r--r--media-libs/babl/babl-0.1.4-r1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/media-libs/babl/ChangeLog b/media-libs/babl/ChangeLog
index 8cb877976831..831849c20fff 100644
--- a/media-libs/babl/ChangeLog
+++ b/media-libs/babl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/babl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.28 2011/05/20 20:15:45 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.29 2011/08/23 15:58:24 nirbheek Exp $
+
+*babl-0.1.4-r1 (23 Aug 2011)
+
+ 23 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +babl-0.1.4-r1.ebuild:
+ Bump babl to ~arch for introspection
20 May 2011; Kacper Kowalik <xarthisius@gentoo.org> babl-0.1.4.ebuild:
ppc/ppc64 stable wrt #360595
diff --git a/media-libs/babl/babl-0.1.4-r1.ebuild b/media-libs/babl/babl-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..be6fd9a2e785
--- /dev/null
+++ b/media-libs/babl/babl-0.1.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.4-r1.ebuild,v 1.1 2011/08/23 15:58:24 nirbheek Exp $
+
+EAPI=3
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+SRC_URI="ftp://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="altivec +introspection sse mmx"
+
+RDEPEND="introspection? ( >=dev-libs/gobject-introspection-0.6.8 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ econf \
+ --disable-static \
+ --disable-maintainer-mode \
+ $(use_enable altivec) \
+ $(use_enable introspection) \
+ $(use_enable mmx) \
+ $(use_enable sse)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ find "${ED}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog README NEWS || die "dodoc failed"
+}