summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-11-20 08:45:23 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-11-20 08:45:23 +0000
commitb8e03df7d8a0abd38abdaa6827c3b9f34e8d4673 (patch)
tree32c0cd36ef177765b18ec91b097a5388452242f6 /media-libs/atlas-c++
parentFixed encoding in ChangeLog (diff)
downloadgentoo-2-b8e03df7d8a0abd38abdaa6827c3b9f34e8d4673.tar.gz
gentoo-2-b8e03df7d8a0abd38abdaa6827c3b9f34e8d4673.tar.bz2
gentoo-2-b8e03df7d8a0abd38abdaa6827c3b9f34e8d4673.zip
Adding all dependency within libraries. Tested with -Wl,-no-undefined
(Portage version: 2.1.4.5)
Diffstat (limited to 'media-libs/atlas-c++')
-rw-r--r--media-libs/atlas-c++/ChangeLog5
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch58
2 files changed, 59 insertions, 4 deletions
diff --git a/media-libs/atlas-c++/ChangeLog b/media-libs/atlas-c++/ChangeLog
index 7775270c8047..136bff651378 100644
--- a/media-libs/atlas-c++/ChangeLog
+++ b/media-libs/atlas-c++/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/atlas-c++
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.26 2008/11/19 14:47:42 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.27 2008/11/20 08:45:23 tupone Exp $
+
+ 20 Nov 2008; <alfredo@gentoo.org> files/atlas-c++-0.6.1-as-needed.patch:
+ Adding all dependency within libraries. Tested with -Wl,-no-undefined
*atlas-c++-0.6.1-r1 (19 Nov 2008)
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch
index 2c7e7a180ce7..c89827be08e9 100644
--- a/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch
@@ -1,11 +1,63 @@
---- Atlas/Net/Makefile.am.old 2008-11-19 15:29:19.000000000 +0100
-+++ Atlas/Net/Makefile.am 2008-11-19 15:30:04.000000000 +0100
+--- Atlas/Makefile.am.old 2008-11-20 08:45:41.000000000 +0100
++++ Atlas/Makefile.am 2008-11-20 08:45:52.000000000 +0100
+@@ -1,4 +1,4 @@
+-SUBDIRS = Message Codecs Filters Net Objects Funky
++SUBDIRS = . Message Codecs Filters Net Objects Funky
+
+ INCLUDES = -I$(top_srcdir)
+
+--- Atlas/Message/Makefile.am.old 2008-11-20 08:47:01.000000000 +0100
++++ Atlas/Message/Makefile.am 2008-11-20 08:47:29.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasMessage_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasMessage_0_6_la_LIBADD = ../libAtlas-0.6.la
++
+ libAtlasMessage_0_6_la_SOURCES = \
+ Element.cpp MEncoder.cpp DecoderBase.cpp QueuedDecoder.cpp
+
+--- Atlas/Codecs/Makefile.am.old 2008-11-20 08:49:49.000000000 +0100
++++ Atlas/Codecs/Makefile.am 2008-11-20 08:52:45.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasCodecs_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasCodecs_0_6_la_LIBADD = ../libAtlas-0.6.la
++
+ libAtlasCodecs_0_6_la_SOURCES = \
+ Utility.cpp XML.cpp Packed.cpp Bach.cpp
+
+--- Atlas/Filters/Makefile.am.old 2008-11-20 08:53:58.000000000 +0100
++++ Atlas/Filters/Makefile.am 2008-11-20 08:55:21.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasFilters_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasFilters_0_6_la_LIBADD = ../libAtlas-0.6.la -lz -lbz2
++
+ libAtlasFilters_0_6_la_SOURCES = \
+ Bzip2.cpp Bzip2.h \
+ Gzip.cpp Gzip.h
+--- Atlas/Net/Makefile.am.old 2008-11-19 15:10:38.000000000 +0100
++++ Atlas/Net/Makefile.am 2008-11-19 15:11:13.000000000 +0100
@@ -5,6 +5,8 @@
libAtlasNet_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
-+libAtlasNet_0_6_la_LIBADD = ../Codecs/libAtlasCodecs-0.6.la
++libAtlasNet_0_6_la_LIBADD = ../Codecs/libAtlasCodecs-0.6.la ../libAtlas-0.6.la
+
libAtlasNetincludedir = $(includedir)/Atlas-C++-0.6/Atlas/Net
libAtlasNet_0_6_la_SOURCES = \
+--- Atlas/Objects/Makefile.am.old 2008-11-20 08:57:39.000000000 +0100
++++ Atlas/Objects/Makefile.am 2008-11-20 08:58:56.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasObjects_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasObjects_0_6_la_LIBADD = ../libAtlas-0.6.la ../Message/libAtlasMessage-0.6.la ../Codecs/libAtlasCodecs-0.6.la
++
+ REAL_GENERATED_CPP = Root.cpp Decoder.cpp Dispatcher.cpp objectFactory.cpp \
+ RootEntity.cpp RootEntityChildren.cpp \
+ RootOperation.cpp RootOperationChildren1.cpp \