summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-18 21:06:18 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-18 21:06:18 +0000
commit7f75188dfba019ef702a8b89d2acdf2193e418a9 (patch)
treedbf222be8b8120e3d9d7a601b5ea3ba1c7314e83 /media-libs/amd64codecs
parentStable on ppc wrt bug #161288. (diff)
downloadgentoo-2-7f75188dfba019ef702a8b89d2acdf2193e418a9.tar.gz
gentoo-2-7f75188dfba019ef702a8b89d2acdf2193e418a9.tar.bz2
gentoo-2-7f75188dfba019ef702a8b89d2acdf2193e418a9.zip
Use $(get_libdir) from multilib.eclass rather than hardcode libdir to lib64.
(Portage version: 2.1.2)
Diffstat (limited to 'media-libs/amd64codecs')
-rw-r--r--media-libs/amd64codecs/ChangeLog6
-rw-r--r--media-libs/amd64codecs/amd64codecs-20061203.ebuild10
2 files changed, 11 insertions, 5 deletions
diff --git a/media-libs/amd64codecs/ChangeLog b/media-libs/amd64codecs/ChangeLog
index 66b122ec9384..8c45d7db709c 100644
--- a/media-libs/amd64codecs/ChangeLog
+++ b/media-libs/amd64codecs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/amd64codecs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/amd64codecs/ChangeLog,v 1.1 2007/01/06 19:37:47 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/amd64codecs/ChangeLog,v 1.2 2007/01/18 21:06:18 phreak Exp $
+
+ 18 Jan 2007; Christian Heim <phreak@gentoo.org>
+ amd64codecs-20061203.ebuild:
+ Use $(get_libdir) from multilib.eclass rather than hardcode libdir to lib64.
*amd64codecs-20061203 (06 Jan 2007)
diff --git a/media-libs/amd64codecs/amd64codecs-20061203.ebuild b/media-libs/amd64codecs/amd64codecs-20061203.ebuild
index 8473e0e17829..75f72f3c62d8 100644
--- a/media-libs/amd64codecs/amd64codecs-20061203.ebuild
+++ b/media-libs/amd64codecs/amd64codecs-20061203.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/amd64codecs/amd64codecs-20061203.ebuild,v 1.2 2007/01/08 02:22:25 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/amd64codecs/amd64codecs-20061203.ebuild,v 1.3 2007/01/18 21:06:18 phreak Exp $
+
+inherit multilib
DESCRIPTION="64-bit binary codecs for video and audio playback support"
SRC_URI="mirror://mplayer/releases/codecs/essential-amd64-${PV}.tar.bz2"
@@ -17,14 +19,14 @@ src_install() {
# see #83221
insopts -m0644
- dodir /usr/lib64/codecs
- insinto /usr/lib64/codecs
+ dodir /usr/$(get_libdir)/codecs
+ insinto /usr/$(get_libdir)/codecs
doins *.so
dodoc README
dodir /etc/revdep-rebuild
cat - > "${D}/etc/revdep-rebuild/50amd64codecs" <<EOF
-SEARCH_DIRS_MASK="/usr/lib64/codecs"
+SEARCH_DIRS_MASK="/usr/$(get_libdir)/codecs"
EOF
}