summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2012-01-26 12:19:09 +0000
committerTony Vroon <chainsaw@gentoo.org>2012-01-26 12:19:09 +0000
commit52e11cf43d414289d8aad7ce9576789bad141d4b (patch)
treeee5d8215399c935f780b4d991e629d974411fe17 /media-libs/alsa-oss
parentDrop failing patch, fixes bug #400893. (diff)
downloadgentoo-2-52e11cf43d414289d8aad7ce9576789bad141d4b.tar.gz
gentoo-2-52e11cf43d414289d8aad7ce9576789bad141d4b.tar.bz2
gentoo-2-52e11cf43d414289d8aad7ce9576789bad141d4b.zip
Version bump, as requested by Mart "leio" Raudsepp on #gentoo-dev. Installation of static libraries is now optional and libtool archives are no longer installed. Please file a bug if either change breaks your application.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/alsa-oss')
-rw-r--r--media-libs/alsa-oss/ChangeLog11
-rw-r--r--media-libs/alsa-oss/alsa-oss-1.0.25.ebuild38
2 files changed, 47 insertions, 2 deletions
diff --git a/media-libs/alsa-oss/ChangeLog b/media-libs/alsa-oss/ChangeLog
index a07cfd8e3490..144b52698fdc 100644
--- a/media-libs/alsa-oss/ChangeLog
+++ b/media-libs/alsa-oss/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/alsa-oss
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-oss/ChangeLog,v 1.118 2009/07/02 19:02:11 ranger Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-oss/ChangeLog,v 1.119 2012/01/26 12:19:09 chainsaw Exp $
+
+*alsa-oss-1.0.25 (26 Jan 2012)
+
+ 26 Jan 2012; Tony Vroon <chainsaw@gentoo.org> +alsa-oss-1.0.25.ebuild:
+ Version bump, as requested by Mart "leio" Raudsepp on #gentoo-dev.
+ Installation of static libraries is now optional and libtool archives are no
+ longer installed. Please file a bug if either change breaks your application.
02 Jul 2009; Brent Baude <ranger@gentoo.org> alsa-oss-1.0.17.ebuild:
Marking alsa-oss-1.0.17 ppc64 for bug 272682
diff --git a/media-libs/alsa-oss/alsa-oss-1.0.25.ebuild b/media-libs/alsa-oss/alsa-oss-1.0.25.ebuild
new file mode 100644
index 000000000000..504985c63a30
--- /dev/null
+++ b/media-libs/alsa-oss/alsa-oss-1.0.25.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-oss/alsa-oss-1.0.25.ebuild,v 1.1 2012/01/26 12:19:09 chainsaw Exp $
+
+EAPI=4
+
+inherit autotools base multilib
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture OSS compatibility layer."
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/oss-lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-1.0.12-hardened.patch" )
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ sed -i -e 's:\${exec_prefix}/\\$LIB/::' "${D}/usr/bin/aoss"
+ find "${D}" -name "*.la" -delete
+}